GAP5 on WindowsXP : Error opening db

  • suhas

    suhas - 2012-07-25

    I have installed the latest GAP5 on windows XP. I am following the exercises given in the documentation. Everything was fine till I run Pregap4 with GAPT4 shotgun assembly. I tried to open the testb.0.aux database file. But it given an error. This is the details of the error

        while executing
    "g5::open_database -name "$db_name" -access $access"
        (procedure "DB_Load" line 33)
        invoked from within
    "DB_Load $file"
        (procedure "Gap_Open" line 10)
        invoked from within
    "Gap_Open $io"
        ("eval" body line 1)
        invoked from within
    "eval {Gap_Open $io}"
        (menu invoke)

    Does anyone knows what's going wrong with it?

  • James Bonfield

    James Bonfield - 2012-07-25

    There were a few problems in the last distribution for windows (a compilation/build issue at our end rather than with the program, but it amounts to the same thing). Apologies for not uploading a new one yet.

    If you have a bin/gap4.exe then try renaming it to gap.exe instead to see if that cures it. It may or may not. (Rename back if not.)  The only other alternative for now is to download an earlier version or compile from source code, which is not recommended for most users due to the complexity involved on Windows.

  • suhas

    suhas - 2012-07-26

    Hi JK,
               thanks a lot for the prompt reply.. You guys are doing a great job. Please do not apologize. I understand that all you folks are still giving us time despite your busy schedules..
       Finally, the workaround  you suggested did work. Just one correction there -  I had to rename the GAP5.exe to gap.exe and everything is working fine.. And to my surprise the tile bar of the window now reads GAP v4.11.2…
       Thanks a lot again for the speedy support!!

  • James Bonfield

    James Bonfield - 2012-07-26

    Ah, I'd advise copying gap.exe back to gap5.exe  Your gap.exe is infact gap4, not gap5. Gap5.exe itself should have worked fine (as be gap5) when it's called gap5.exe.

    They are all infact the same executable (well the Tcl/Tk programs are), which is just a small wrapper to set up some environment and then launch the real program. They look at the name of the program being run to work out which to launch. The problem here was that the gap4 directory didn't exist (rather it was called "gap" in that distribution), hence needing gap4.exe renamed to gap.exe.

    Ie the filename is what matters most for these tools and by renaming them you're actually changing the program being run.


Log in to post a comment.