Compilation in Ubuntu 10.04 meets Errors

zhaoging
2010-08-26
2013-04-18
  • zhaoging

    zhaoging - 2010-08-26

    Hi,

    I am a newbie in Ubuntu and STADEN as well.  I couldn't build the STADEN up though I have installed all the required third-party packages. This is the result after typing ../configure command,


    External packages used:
    curl:      via /usr/bin/curl-config
    zlib:      DIR (system)
    ncurses:   DIR (system)
    liblzma:   DIR
    samtools:  DIR /usr/bin/samtools-0.1.8
    io_lib:    via /usr/bin/io_lib-config
    Tcl:       via /usr/lib/tcl8.5/tclConfig.sh
    Tk:        via /usr/lib/tk8.5/tkConfig.sh
    tklib:     /usr/share/tcltk/tklib0.5
    Iwidgets:  /usr/share/tcltk/iwidgets4.0.1
    Itcl:      /usr/share/tcltk/itcl3.4
    Itk:       /usr/share/tcltk/itk3.3


    Next, I 'make' it….

    and errors occured !

    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1099: error: ‘Sheet’ has no member named ‘greygc’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1100: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1101: error: ‘Sheet’ has no member named ‘yflip’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1101: error: ‘Sheet’ has no member named ‘rows’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1101: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1101: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1102: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1103: error: ‘Sheet’ has no member named ‘yflip’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1103: error: ‘Sheet’ has no member named ‘rows’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1103: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1103: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1107: error: ‘Sheet’ has no member named ‘normgc’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1108: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1109: error: ‘Sheet’ has no member named ‘yflip’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1109: error: ‘Sheet’ has no member named ‘rows’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1109: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1109: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1110: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1111: error: ‘Sheet’ has no member named ‘yflip’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1111: error: ‘Sheet’ has no member named ‘rows’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1111: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1111: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1115: error: ‘Sheet’ has no member named ‘greygc’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1116: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1117: error: ‘Sheet’ has no member named ‘yflip’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1117: error: ‘Sheet’ has no member named ‘rows’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1117: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1117: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1118: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1119: error: ‘Sheet’ has no member named ‘yflip’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1119: error: ‘Sheet’ has no member named ‘rows’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1119: error: ‘Sheet’ has no member named ‘border_width’
    /home/zhaoging/staden-2.0.0b7-src/build.myhost/../tk_utils/sheet.c:1119: error: ‘Sheet’ has no member named ‘border_width’

    seems like the 'sheet.c' couldn't be compiled

    and the 'make' process die then……

    can anybody tell me why did this happen?

     
  • James Bonfield

    James Bonfield - 2010-08-31

    Were there any errors before these, eg couldn't find inclue file X11.h (or something similar)? I'm wondering what's missing. My first guess would be the "x-dev" package. It's probably something we should check for in the configure script.

     
  • Anonymous - 2010-09-02

    I just managed to build and install staden-2.0.0b7-src on Ubuntu 10.04 (amd64).
    I checked my make log and was missing X11/Intrinsic.h
    I needed libxt-dev

    This sequence of commands may work for you:
    tar -zxvf staden-2.0.0b7-src.tar.gz
    mkdir staden-2.0.0b7-src.tar.gz/build.ubuntu
    cd staden-2.0.0b7-src.tar.gz/build.ubuntu
    ../configure
    make
    sudo make install

     
  • Anonymous - 2010-09-02

    Oops, that sequence of commands won't work for you..

    It should be something more like this:

    tar -zxvf staden-2.0.0b7-src.tar.gz
    mkdir staden-2.0.0b7-src/build.ubuntu
    cd staden-2.0.0b7-src/build.ubuntu
    ../configure
    make
    sudo make install

     
  • James Bonfield

    James Bonfield - 2010-09-03

    Thanks for this. It can be hard to spot all the dependencies when they happen to be already installed on my test systems. I'll make a not to check for this in the configure script.

     
  • Brad Rauh

    Brad Rauh - 2010-09-24

    I'm also a bit of a newbie (Ubuntu 10.04), fresh off a successful phred/phrap/consed install but… I' m having some issues with the configure file finding all the dependencies I installed using synaptic package manager. including :  staden-io_lib =1.12.2, samtools  =0.1.7, tcl  =v8.5, tk =8.4.16-2, zlib =1.2.,  xz utils =4.999,  libpng =1.2.42, curl =7.19.2,  tklib =0.5.2, itcl =3.2, itk  =3.2, iwidgets  =4.0, g++         v4.4, f2c.c, and gfortran.
    I tried using gedit to change the place for the dependencies but it seems that didn't work.  I can add the info to the configure command as stated in the README but I don't even know where synaptic puts some of them.  Any help on this matter would be appreciated.

     
  • Nobody/Anonymous

    The -with-package=dir parameters control where configure finds things. Typically dir is just the root directory of the package, so if it has a bin, lib, etc, include subdirs then it'd be the parent of those. However the options are really only there for people who need to install packages without being root. The main system ones effectively are equivalent to saying -with-libpng=/.

    The expection here is possibly staden-io_lib, which may not have a standard ubuntu package, and samtools. Samtools doesn't have a proper "make install" target either, so I tend to use -with-samtools=/path/to/samtools/src. Just compile up samtools (with -fPIC, edit its Makefile) and specify the directory you unpacked and compiled in.

    I can have an experiment with Ubuntu 10 maybe next week. We don't have a local install, but I can get a VM of it most likely.

     
  • Brad Rauh

    Brad Rauh - 2010-10-13

    back again.  I finally figured out the samtools install and got all the -dev packages that I was missing before (what I was missing before) and got a suceessful ./configure.  when I 'make' the Makefile everything was churning along until I got the following error:

    /usr/bin/ld: /usr/local/bin/samtools-0.1.8//libbam.a(bam_import.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
    /usr/local/bin/samtools-0.1.8//libbam.a: could not read symbols: Bad value
    collect2: ld returned 1 exit status
    make: ***  Error 1
    make: Leaving directory `/usr/local/software/src/compile/staden-2.0.0b7-src/build.ubuntu/gap5'
    make: ***  Error 2
    brauh@DGBlabmgr:/usr/local/software/src/compile/staden-2.0.0b7-src/build.ubuntu$

    can anyone help me with the debug of this?
    Thanks in advance

     
  • James Bonfield

    James Bonfield - 2010-10-14

    This is a problem with the build of Samtools. If you add "-fPIC" to the CFLAGS in the Samtools Makefile and do a full rebuild (make clean; make) then the problem should go away.

    In time I'm considering rewriting the bits of samtools that I depend on so we no longer need to link against the library, but that won't happen soon I guess.

    James

     
  • Brad Rauh

    Brad Rauh - 2010-10-15

    Thank you, I was adding -fPIC in the wrong place in samtools and that fixed that problem.  Now I have another error that may or may not be a big problem:

    /usr/bin/ld: /usr/local/bin/samtools-0.1.8//libbam.a(bam_import.o): relocation R_X86_64_32 against `.rodata.str1.1' can not be used when making a shared object; recompile with -fPIC
    /usr/local/bin/samtools-0.1.8//libbam.a: could not read symbols: Bad value
    collect2: ld returned 1 exit status
    make: ***  Error 1
    make: Leaving directory `/usr/local/bin/staden-2.0.0b7-src/build.ubuntu/gap5'
    make: ***  Error 2

    Is this a missing dependency or the wrong version or something completely different?

     
  • James Bonfield

    James Bonfield - 2010-10-19

    It looks like the same problem to me. You need to do a full rebuild of samtools after changing the Makefile. If it doesn't have a "make clean" target then "rm *.o" will suffice. Then make again as normal.

     
  • Nobody/Anonymous

    Hi,
    I am installing 2.0.0.B7 on MacOSX 10.6.4 with the following configure :
    ../sh-3.2# ../configure -with-tklib=/System/Library/Tcl/tklib0.4/ -with-samtools=/Users/johnsoong/Downloads/samtools-0.1.11/ -with-iwidgets=/System/Library/Tcl/iwidgets -with-itcl=/usr/local/lib/itcl3.4/ -with-itk=/usr/local/lib/itk3.4/
    ,which passes and creates the files in the subdirectory.
    configure: creating ./config.status
    config.status: creating Makefile
    config.status: creating system.mk
    config.status: creating shlib.conf
    config.status: creating staden_config.h


    External packages used:
    curl:      via /usr/bin/curl-config
    zlib:      DIR (system)
    ncurses:   DIR (system)
    liblzma:   DIR
    samtools:  DIR /Users/johnsoong/Downloads/samtools-0.1.11/
    io_lib:    via /usr/local/bin/io_lib-config
    Tcl:       via /Library/Frameworks/Tcl.framework/tclConfig.sh
    Tk:        via /System/Library/Frameworks/Tk.framework/tkConfig.sh
    tklib:     /System/Library/Tcl/tklib0.4/
    Iwidgets:  /System/Library/Tcl/iwidgets
    Itcl:      /usr/local/lib/itcl3.4
    Itk:       /usr/local/lib/itk3.4


    However, when make i get the exact same error as the original post --something wrong when building sheet.c, which depends on X11/Intrinsic.h
    Trying to fix this, I updated the XCODE to the latest version but still no luck.

    I am kind of confused with and amateur with this, please let me know if additional info would help solve this.
    Thanks in advance for any advice!

     
  • Nobody/Anonymous

    Hi,
    I am the previous post author. I solved the build issue by utilizig macport tcltks.
    however, all my executables result in segmentation fault,
    Still need help. Thanks!

    John Soong

     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks