Bug reports: Mac DMG version gap5_export

John Nash
  • John Nash

    John Nash - 2011-12-16

    Unpacked the DMG version.  Installed it into /Applications/Staden.  Added /Applications/Staden/bin to the system path.

    Checked that it worked (gap5 and tg_index work).

    When I tried gap5_export and gap5_check, I get:

    Endeavour:~ johnnash$ gap5_export
    application-specific initialization failed: Can't find a usable init.tcl in the following directories:
        /nfs/sam_scratch/jkb/MacPorts/lib/tcl8.5 /Applications/Staden/bin/../lib/tcl8.5 /Applications/Staden/bin/lib/tcl8.5 /Applications/Staden/bin/../library /Applications/Staden/bin/library /Applications/Staden/bin/tcl8.5.11/library /Applications/Staden/tcl8.5.11/library

    This probably means that Tcl wasn't installed properly.

    can't read "auto_path": no such variable
        while executing
    "foreach x $auto_path {
        set _p($x) 1
        (file "/Applications/Staden/bin/../share/staden/etc/shlib.conf" line 6)
        invoked from within
    "source $env(STADTABL)/shlib.conf"
        (file "/Applications/Staden/bin/../share/staden/tcl/gap5/gap5_export.tcl" line 13)

    Tcl is the Macports installation, so I expect it to be in /opt/local/lib/tcl8.5/init.tcl and of course, Staden has put it in /Applications/Staden/share/tcltk/tcl8.5/.  Should that location be added to the set above?


  • John Nash

    John Nash - 2011-12-16

    And the fix:


    export TCL_LIBRARY=$STADENROOT/share/tcltk/tcl8.5
    export TK_LIBRARY=$STADENROOT/share/tcltk/tk8.5

    to the shell script with the naughty behaviour.


  • James Bonfield

    James Bonfield - 2011-12-16

    Good catch. There's probably a few more like that. I rushed to get it out of the door before Christmas as I'm away next week, but hoping that in the new year I can go through the inevitable quirks and produce an updated set of binaries.  I deliberately bundled everything in the same directory tree (despite the fact it's likely you'll have other copies) as it's less likely to have version clashing - *especially* with tcl/tk which are likely to find aqua builds on the system instead.

    Thanks for the report and fix.


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks