Interactive clipping - no editing?

  • Andrew Warry

    Andrew Warry - 2010-12-08

    I was trying to use the Pregap4 interactive clipping module (staden-2.0.0b6-x86_64 on two RedHat ES5 machines) to check some traditional preprocessing on some .scf files but was unable to use the Quality/Vector cut off editing functions, however these functions worked fine when directly testing Trev from the commandline.

    I took a look at the interactive_clip.p4m code and changing (line 51) from
    if {[catch {set fd [open "|stash

    • -pregap_mode -editscf  -fofn "]} var]} {
      if {[catch {set fd [open "|trev -pregap_mode -editscf  -fofn "]} var]} {

    seems to have solved the issue for me, but I was wondering if there was something wrong with my configuration or if there might be a better way to fix this.



  • Andrew Whitwham

    Andrew Whitwham - 2010-12-10

    Hi Andrew,

    It looks like a fine way to fix it.

    We've been moving away from the use of stash and just keeping it around for the older pieces of code.  It is possible that it does not work properly from the installation now.  I will make myself a RedHat installation a check to see that it still works.




Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks