Problems with x86_64 version

2008-01-15
2013-04-18
  • Nobody/Anonymous

    Hi,

    I've installed today the latest X68_64 version. However I receive an error message when trying to open a database:

    ----------------------------------------

    invalid command name "load_alignment_matrix"
        while executing
    "load_alignment_matrix       [keylget gap_defs ALIGNMENT.MATRIX_FILE]"
        (file "/usr/local/share/staden/linux-x86_64-bin/../lib/gap/gap.tcl" line 683)
    ---------------------------------------------

    pregap4 works fine by the way...

    Any help,

    Regards,

    Carlos

     
    • James Bonfield

      James Bonfield - 2008-01-17

      Try setting the STADEN_DEBUG variable to 1 and launch again. It should say:

      load libcopy_reads.so =>
      load libitcl3.3.so =>
      load libitk3.3.so =>
      load libiwidgets.so => couldn't load file "libiwidgets.so": libiwidgets.so: cannot open shared object file: No such file or directory
      load libcap2.so =>
      load libcap3.so =>
      load libfak2.so =>
      load libphrap.so =>
      load libhaplo.so =>
      load libgap.so =>

      You can ignore the iwidgets complaint. This arises simply as for every tcl package it loads it attempts to load a set of compiled C interfaces too, but this package is pue Tcl so the error is expected.

      I'd guess you have a system library missing causing libgap.so to fail to load.
      Getting the complete list of dependencies is rather awkward as every linux distribution seems to package up libraries in different ways and with differing package names.

      James

       

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks