Hi,

I tried to configure the new node with a local boot device on OpenSSI 0.9.6 release 3 but got some problems.

1. On the new joined nodes, after creating /dev/sda1 by fdisk, I got the message list below when running mkfs to make a filesystem on it.

/dev/sda1 is mounted; will not make a filesystem here!

   If the new created disk partition is not /dev/sda1 (e.g. /dev/sda3 or /dev/hda1), then the mkfs runs correctly on the local hard drive. It seems that the kernel treats /dev/sda1 as the root partition even it's a local device of the new nodes.

2. chnode should run on any node, but in the node without /dev/sda1 (the root device in my environment), there will be an error message list below.

addnode: fatal error:
  Field 5 (boot device) of line 26 of /etc/clustertab must refer to a block device.

  Line 26 of /etc/clustertab describe the first (root) node configuration.

3. I'd also tried to configure a new node with /dev/sda1 and /dev/sda4 and run chnode just on the node to configure /dev/sda4 as the local boot device. chnode run without the messages list above but got the message:

Error migrating to node1. Try again!

  The local boot device still can't be configured. Is there anything I did wrong to cause the problems or they are caused by the bugs?

Regards,

Denny

Business Development Dept.
Dimension Computer Technology Co., Ltd.
>> an e-Solution Provider <<

Phone: +886 2 2501 5568 ext. 349
Fax: +886 2 2505 5134
e-mail: denny.chou@sd.dimension.com.tw
Web: http://www.dimension.com.tw