John Hughes wrote:

(for Lenny the problem is worse, it really needs 2.6.18, my Lenny preview needs some hacked non-SSI packages to work).

Actually Lenny wants 2.6.26, needs 2.6.18 and can be hacked to work with 2.6.12 if some packages are modified.  The last "solution" is a real hack as the number of packages that need modification is difficult to determine - I've "fixed" the ones I came across, but their may be more, and it may not be possible to "fix" them all.