I am working with openssi clusters using versions 1.2 and 1.91, both on Debian. For several long winded reasons, I would very much like to use traditional LVS instead of the ssi provided ha-lvs. But I'm having trouble getting it to work... The behavior is identical on both clusters. The first time I set it up, everything worked great until a reboot. Then no connections show up in ipvsadm -l and no kernel routing seems to take place. Connections just go straight to the node hosting the virtual IP.
If I echo 1 > /proc/sys/net/ipv4/vs/loadbalance on the director, then the director will start loadbalancing to its loopback address with the Local route and those connections start appearing in ipvsadm -l, but still no balancing to other nodes.  The odd thing is that it worked until a reboot. Its like ha-lvs created the correct sysctl variables (or possibly something else?) for LVS to work, but if I don't run it, no kind of LVS can work. What openssi changes to the traditional LVS model do I need to compensate for?