Hi ,
Thanks .
But now I have gotten rid of linuxrc , so default behaviour for ordinary kernel should be to go straight to /sbin/init . But openssi kernel gives kernel panic .
I have tried giving kernel paramater init=/sbin/init and other values for this parameter but it is always gives kernel panic .
It appears the openssi kernel REQUIRES linuxrc ? Then how do I make it ignore that linuxrc is not there ?
Any suggestions appreciated .
Aneesh wrote :
In OpenSSI /sbin/init is started in a bit different way than the base
kernel. It is not started by the kernel. Rather one of the cluster
command start the init . This cluster command is executed from the
linuxrc and  will result in starting /sbin/init only on master node.
Aleks wrote :
> Hi ,
> Trying to do an experiment where I load the entire operating system into
> memory . I have done this successfully by copying all my files into the
> initrd image ( the ramdisk image ) . In grub.conf , kernel parameter root
> looks like
> root=/dev/ram0 . And I have to delete linuxrc from the ramdisk . This works.
> But when I install openssi and follow this procedure , I get 'kernel panic ,
> init not found , try passing init= parameter to kernel' .
> Anybody know why this might be occuring ? I tried copying stuff from the
> openssi ramdisk into my complete ramdisk .This does not help .....Is the
> openssi kernel very picky about its ramdisk ?