#59 rc5 - dd if=/dev/1/zero of=/dev/null crashes node

closed-fixed
Devices (3)
2
2004-06-29
2004-05-27
Anonymous
No

On a node other than 1 dd if=/dev/1/zero of=/def/null
crashes the node.

It seems to be in an infinite recursion:

... cfs_dev_open calls
ssidev_remote_open calls
ssidev_local_open calls
dentry_open calls
dentry_open_it calls
cfs_dev_open ...

Discussion

  • Brian J. Watson

    Brian J. Watson - 2004-05-27
    • labels: --> Devices
    • priority: 5 --> 2
    • assigned_to: nobody --> vvinod
     
  • John Byrne

    John Byrne - 2004-05-28

    Logged In: YES
    user_id=296930

    If this code was working the way it was intended to, this
    command probably wouldn't probably wouldn't work as
    expected. /dev/zero and /dev/null are treated as special
    cases and all attempts to open them are supposed to open the
    device on the local node. So, if this was an attempt to
    measure local vs remote performance, it wouldn't have worked
    as expected. If things were working, of course.

     
  • Vinod Vijayarajan

    • assigned_to: vvinod --> jlbyrne
     
  • Vinod Vijayarajan

    Logged In: YES
    user_id=945844

    John knows what's wrong and will be working to fix it.
    Reassigning this bug

     
  • John Byrne

    John Byrne - 2004-06-29
    • status: open --> closed
     
  • John Byrne

    John Byrne - 2004-06-29
    • status: closed --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks