Problems on Windows Server 2003

Help
Rodel
2008-06-23
2012-07-18
  • Rodel

    Rodel - 2008-06-23

    I am trying to get OpenSSH ver 3.8.1 to work on Windows Server 2003. I am trying to connect through public authentication I tried to follow the instruction found on this link, http://www.cs.bham.ac.uk/%7Esmp/projects/ssh-windows/. I could do all but enable UsePrivilegeSeparation in the sshd_config file. When I enabled it the OpenSSH service would not start.

    I tried testing the OpenSSH again with the command ssh username@ipadress, but it would open the connection and then close it. When I check the application log on the computer I get the following error:
    The description for Event ID ( 0 ) in Source ( sshd ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: sshd : PID 1352 : fatal: setreuid 1006: Permission denied.

    I then added my user to the administrator group and made sure that it had read, write, and execute rights to C:\Program Files\OpenSSH.

    I still get the same error on the computer. I installed OpenSSH on another computer tht has windows XP and it had no problems connecting. I am just trying to get it to work on the computer with the Windows server 2003. Thanks for any help you can provide.

     
  • TGP1994

    TGP1994 - 2012-05-12

    I know that this is an old topic, but I'm having the same issue, on the same
    operating system. I just setup public key authentication when this started
    happening.

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks