#4 Unsuccesful installation for gnome menu

closed
None
5
2008-04-14
2008-04-07
v1pEr
No

The installation doesn't show any errors:

19:12 elise:../sshmenu-3.15 # make install
install -d /usr/bin /usr/lib/ruby/1.8 /usr/lib/bonobo/servers
install -d /usr/lib/gnome-panel /usr/share/icons/hicolor/48x48/apps
install -d /usr/share/man/man1
install -m644 lib/sshmenu.rb /usr/lib/ruby/1.8/sshmenu.rb
install -m644 lib/gnome-sshmenu.rb /usr/lib/ruby/1.8/gnome-sshmenu.rb
install -m644 sshmenu-applet.server /usr/lib/bonobo/servers/sshmenu-applet.server
install -m755 sshmenu-applet /usr/lib/gnome-panel/sshmenu-applet
install -m644 sshmenu.1 /usr/share/man/man1/sshmenu.1
install -m644 gnome-sshmenu-applet.png /usr/share/icons/hicolor/48x48/apps/gnome-sshmenu-applet.png
install -m755 bin/sshmenu /usr/bin/sshmenu
install -m755 bin/sshmenu-gnome /usr/bin/sshmenu-gnome

But when I try to add the applet to the gnome menu I get an error. More verbose information here:

19:19 elise:../sshmenu-3.15 # sshmenu-gnome
/usr/lib/ruby/1.8/sshmenu.rb:5:in `require': no such file to load -- gtk2 (LoadError)
from /usr/lib/ruby/1.8/sshmenu.rb:5
from /usr/lib/ruby/1.8/gnome-sshmenu.rb:1:in `require'
from /usr/lib/ruby/1.8/gnome-sshmenu.rb:1
from /usr/bin/sshmenu-gnome:3:in `require'
from /usr/bin/sshmenu-gnome:3

Apparantly I need libgtk2-ruby but it doesn't seem to exist for openSuSE 10.3 ?

Any help would be appreciated :)

Discussion

  • Grant McLean

    Grant McLean - 2008-04-14
    • assigned_to: nobody --> grantm
    • status: open --> closed
     
  • Grant McLean

    Grant McLean - 2008-04-14

    Logged In: YES
    user_id=242694
    Originator: NO

    The tarball distribution of SSHMenu is really not intended for casual users. Knowing the correct locations for 'make install' to write to on every platform is a job best left to package maintainers familiar with those platforms. I have built reference packages for Debian/Ubuntu but don't have any expertise to package for other platforms.

    There is a link on the Ruby-GNOME2 web site to pre-built packages for SUSE 10.0: perhaps you could adapt the spec files to build packages of the latest source for SUSE 10.3: http://ruby-gnome2.sourceforge.jp/hiki.cgi?Install+Guide+for+SUSE

     

Log in to post a comment.