#430 Plugin listcommands appears to mishandle default id

closed-works-for-me
Compose (50)
5
2007-06-24
2007-04-17
No

When the default e-mail account is being selected to unsubscribe from a mailinglist then this address is given the label 0. Only compose doesn't seem to be able to handle this, but is able to handle the name 'default' instead. If the default e-mailaddress isn't being labeled as 'default' then the inlogname + domain seems to be used as sender.

Attached patch fixes this and has been tested to 1.4.9a + svn towards latest stable.

Discussion

  • Anonymous - 2007-04-17

    Force id 0 to be named as default

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2007-04-18

    Logged In: YES
    user_id=285765
    Originator: NO

    Thanks. Are you sure that the bug is still present in current stable SVN? This is supposed to be fixed in revision 12280 on 2007-02-27.

     
  • Anonymous - 2007-04-18

    Logged In: YES
    user_id=457236
    Originator: YES

    The version you refer to isn't part of SM-1_4-STABLE, but I haven't testen the trunk. Also the trunk appears to differ too much in this stage from the 1.4 branch to be merged. Then again, I'm not sure if the attached patch covers all the ground to solve the issue for the 1.4 branch. This may be something I need to check.

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2007-05-03

    Logged In: YES
    user_id=285765
    Originator: NO

    Have you verified the problem still being present in an up to date SM-1_4-STABLE checkout? Sorry to ask so many questions but I'm a bit short on time and a little help like this makes a difference :)

     
  • Anonymous - 2007-05-03

    Logged In: YES
    user_id=457236
    Originator: YES

    No problems. I do a SVN update every week of SM-1_4-STABLE and sync it with my own tree and this one keeps hitting the light when I do a diff between the two trees. And when I browse the repository I still see the same thing. The fix you refer to seems to be fixed in the trunk due to a rewrite, but didn't check that yet.

    Hope you can get it in for 1.4.10 or do you want a new patch to accept value "0" to be seen as the value "default"? Maybe this can be done later this day, but it doesn't get the testing it may need and the current patch works for me at least in development, test and production. Or I can create a patch for 1.4.11 to clean things up. Its your call.

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2007-05-03
    • assigned_to: nobody --> kink
     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2007-05-03

    Logged In: YES
    user_id=285765
    Originator: NO

    I'll check it out tomorrow, and if the fix is limited enough I'll include it in 1.4.10. It's just that I wanted to be sure that the problem is actually still present.

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2007-05-04
    • status: open --> open-works-for-me
     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2007-05-04

    Logged In: YES
    user_id=285765
    Originator: NO

    I've checked it out and it just works for me. The sending of the message happens with the correct values for the first identity, as expected.

    Inspection of the code yields that both compose.php and mailout.php have exactly the same HTML code as the forms to select an identity, both with '0' as the key for the first. Also the code generating that HTML works exactly the same in both locations: a get_identities() call which is then iterated over without anything special.

    I am really wondering what the difference between your and my setup is.

     
  • Anonymous - 2007-05-08

    Logged In: YES
    user_id=457236
    Originator: YES

    It may be wise to skip this one for now and take a closer look after the 1.4.10 release. I'm currently building a new development server anyway so this may be a good place as reference.

     
  • Anonymous - 2007-06-22

    Logged In: YES
    user_id=457236
    Originator: YES

    This bug can be closed since bug doesn't seem to appear in 1.4.10a. 1.4.10a even complains that the keyword default is invalid. I suspect an out of sync tree with the squirrelmail tree.

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2007-06-24

    Logged In: YES
    user_id=285765
    Originator: NO

    Thanks, closed.

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2007-06-24
    • status: open-works-for-me --> closed-works-for-me
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks