It seems that if the original message appears or not at the answer it depends on the codification of the sender of the original message, because even with interface in english some answers do not include the original message.


On Wed, November 7, 2012 12:59, "Andrés Chandía" wrote:
Taka patch turned everything blank, from the login page onwards, so I went back to my previous version and patched again with the other two patches, now I realized that the original message is included in the answer if I change the web interface visualization options to english, in spanish still does not appears, and at the address book still happens de same, I mean, names with accents ar not seen even with the interface in english.

Thanks


On Tue, November 6, 2012 22:56, Tomas Kuliavas wrote:
> "Andrés Chandía" wrote
>> Thanks Tomas.
>>
>> this patch did nothing to my sm: http://pastebin.com/3RQCUEV4
>>
>> this one fixed the subject and sender and body issues:
>> http://pastebin.com/sWJTzGCL
>>
>> but I still don't get the original message at the answer mail, should I
>> apply also the
>> patch porposed
>> by taca:
>> http://doga.jp/~taka2/archive/squirrelmail-webmail-1.4.22-PHP54jaJP_20120705taka2.diff
>
> Taka's patch alone should be enough, if you fix
>
> return htmlspecialchars($string, ENT_COMPAT | ENT_HTML401, $encoding);
>
> to
>
> return htmlspecialchars($string, ENT_COMPAT, $encoding);
>
> in sq_htmlspecialchars function (in functions/i18n.php).
>
> Please note that you are running SquirrelMail package created by Debian with
> patches that can make it incompatible with stock SquirrelMail used by Taka's
> patch.
>



_______________________
andrés chandía
chandia.net
P No imprima innecesariamente. ¡Cuide el medio ambiente!


_______________________
            andrés chandía
chandia.net
P No imprima innecesariamente. ¡Cuide el medio ambiente!