#126 multiple message delete not working


When SquirrelMail has multiple pages of messages,
multiple message delete does not work.

1. select several messages
2. delete them
3. select more messages and delete them

Problem: The second set of selected messages are not
deleted. (Changing the page number doesn't correct the

Workaround: Click on the Inbox again.

This is in 1.4.4. Did not see the problem mentioned in
the 1.4.5/1.4.6 fixes or in the bug tracker.

PHP 4.3.10.
Apacheh 1.3.33 (Unix)



  • Tomas Kuliavas

    Tomas Kuliavas - 2005-09-26

    Logged In: YES

    php register_globals setting?

  • Trent

    Trent - 2005-09-27

    Logged In: YES

    register_globals is on

  • Jonathan Angliss

    Logged In: YES

    I don't see a mention of an IMAP server. If your IMAP
    server supports the SORT extension, try enabling it in the
    SquirrelMail configuration. It is listed as enable_server_sort.

  • Nobody/Anonymous

    Logged In: NO

    register_globals is On at 2 of my sites (different servers)
    with the problem.

  • Tomas Kuliavas

    Tomas Kuliavas - 2005-09-27

    Logged In: YES

    SquirrelMail developers program with register_globals = off.
    It allows to use SquirrelMail in setups, that don't register
    global variables automatically, but it can also cause
    variable corruption and security issues when these variables
    are registered automatically.

    Since 1.3.0 and 1.29 SquirrelMail can run in rg=off setups.
    There are known issues with register_globals = on. Please
    turn off register_globals and check if you still can
    reproduce your problem.

    If some script requires rg=on, turn on register globals only
    for that script. You can do it in apache configuration and
    .htaccess files.

  • Nobody/Anonymous

    Logged In: NO

    i-had got the same problem with deleting.
    config :
    - squirrel mail 1.4.5
    - apache 2
    - php 4 /register_globals=off
    - hmailserver
    - xp pro :-}

    first list deleting works fine, second displays :
    Error COPY xx,xx,x To "trash_folder" where "trash_folder" is
    my personal trash folder name.

    but funny thing, this error appears only sometimes not
    always. i'm developper so i tried to solve it but this is still
    shrouded in mystery for me...

    excluding that ball, hubba huuba for your program.

  • Nobody/Anonymous

    Logged In: NO

    I am having a similar problem. Have be looking for bug
    reports but find nothing.
    Have :
    php 4.4.0
    squirrelmail 1.45 , 1.46 cvs , 1.50
    IMAP c-Client Version 2000

    register_globals = off using an .htaccess file

    the problem happens allways in this way.

    Folder with a few pages of mails
    Click "Show all"
    Select one or more mails to delete.

    Then the mail/s is still present there but really have be
    deleted (the refresh done after deleting is false). at this
    point if I try to delete more mails the program doesn't give
    any error, but the mails are not deleted

    I could solve this refreshing the mails window clicking at
    the folder where I am working

  • john_johnstone

    john_johnstone - 2006-01-09

    Logged In: YES

    I am also seeing this problem with versions 1.4.5 and
    1.4.6-rc1. I don't have the problem with 1.4.4-rc1.
    This is with both Firefox and IE on WXP.

    Red Hat Linux 3.2.2-5
    PHP 4

  • Tomas Kuliavas

    Tomas Kuliavas - 2006-01-10

    Logged In: YES

    issue is specific to 1.4.x branch. when listing is not
    paginated, interface uses message cache. In some cases it
    causes listing errors (use of message cache when $msgs is
    unset) or move_messages.php script retains use_message_cache
    argument in URL when cache is not updated.

  • Tomas Kuliavas

    Tomas Kuliavas - 2006-01-10

    Logged In: YES

    It might be hard to reproduce errors with toggle all,
    because they might depend on frame load order.

    Just check right_main.php tests in line 205 and see how they
    handle $use_mailbox_cache=1, when $msgs is not in session.
    showMessagesForMailbox() breaks if last argument is set to
    true and $msgs is not in session. Error in test login can
    cause E_NOTICE level errors and Unknown sender/No subject.

    We can also fix showMessagesForMailbox() instead of fixing
    right_main.php logic.

    Modification in move_messages.php should disable caching on
    every operation with messages.

  • Tomas Kuliavas

    Tomas Kuliavas - 2006-05-06

    Logged In: YES

    Issue should be fixed in 1.4.7cvs.

  • Tomas Kuliavas

    Tomas Kuliavas - 2006-05-06
    • status: open --> closed-fixed
  • Chris Lott

    Chris Lott - 2006-12-11

    Logged In: YES
    Originator: NO

    I'm writing to ask if this has been fixed in 1.4.7. I use webmail provided by Pair.com; they use SM version 1.4.5. I've been nudging them about this exact issue without any success for many months. Frankly I don't know how to test this one since for me it's not easily repeatable. I thought it was a delete problem since I only noticed it while deleting messages. Later I realized it's actually a caching problem, as others have noted here, because refreshing the inbox causes the headers page to be repainted and then I see the expected messages. So if you can provide some evidence I'd like to point theim at this bug report. Thanks in advance.


Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

No, thanks