SourceForge has been redesigned. Learn more.
Close

#2421 Send fails

closed-invalid
nobody
Compose (426)
5
2007-07-21
2007-01-20
No

Environment:

FreeBSD 4.11-stable
apache+mod_ssl-1.3.37+2.8.28
php5-5.2.0
php5-gettext-5.2.0
php5-mbstring-5.2.0
php5-mhash-5.2.0
php5-openssl-5.2.0
php5-pcre-5.2.0
php5-session-5.2.0
php5-xml-5.2.0
squirrelmail-1.4.9a
imap-uw-2004g_1,1

I have used SM successfully for several years
without problems. I just upgraded to 1.4.9a.
When I attempt to send mail after it is composed
I get "Error 354" after a very long (45 sec) wait.
The mail does get sent but does not show up in
the sent folder.

Ideas?

Discussion

  • Thijs Kinkhorst

    Thijs Kinkhorst - 2007-01-20

    Logged In: YES
    user_id=285765
    Originator: NO

    What exactly gives that "Error 354"?

     
  • Tim Daneliuk

    Tim Daneliuk - 2007-01-20

    Logged In: YES
    user_id=186330
    Originator: YES

    The 354 error occurs after you compose a message and attempt to send it.
    The systems goes into a long wait and eventually SM comes up with "ERROR. Server replied
    with 354". THe message *does* get sent, but does not show up in the send folder.

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2007-01-21

    Logged In: YES
    user_id=285765
    Originator: NO

    So the message is generated by the server software. Do the logs of the IMAP or SMTP server (not sure which generates the message) have more detailed information?

     
  • Tim Daneliuk

    Tim Daneliuk - 2007-01-28

    Logged In: YES
    user_id=186330
    Originator: YES

    No errors show up in either /var/log/maillog or /var/log/messages. However, apache
    reports the following:

    [Sun Jan 28 14:18:13 2007] [error] PHP Notice: Undefined property: Deliver_SMTP::$dlv_msg in /usr/local/www/squirrelmail/src
    /compose.php on line 1615
    [Sun Jan 28 14:18:13 2007] [error] PHP Notice: Undefined property: Deliver_SMTP::$dlv_server_msg in /usr/local/www/squirrelm
    ail/src/compose.php on line 1617

     
  • Jonathan Angliss

    Logged In: YES
    user_id=620333
    Originator: NO

    354 isn't an error code, but a continuation code issued after the "DATA" command. This sounds like your server is doing some kind of validation after the recipient, and the sender information. You should check your mail services, and ensure that if it is performing any sender validation, that the server has proper access to the servers it is using (RBLs?), and that DNS is operating correctly.

     
  • Paul Lesniewski

    Paul Lesniewski - 2007-07-19

    Logged In: YES
    user_id=508228
    Originator: NO

    IIRC, isn't this a mod_security issue? I think some common mod_security settings generate false positives on src/compose.php (which should be whitelisted). It's also late at night, so my memory could be incorrect.

     
  • Tim Daneliuk

    Tim Daneliuk - 2007-07-21

    Logged In: YES
    user_id=186330
    Originator: YES

    As Jangliss suggested, this may have been a failing RBL lookup. Things seem to be
    back to normal now that I allow mail to proceed even if the RBL never answers....

    Thanks for all the help...

     
  • Paul Lesniewski

    Paul Lesniewski - 2007-07-21
    • status: open --> closed-invalid
     

Log in to post a comment.