#2161 SSL proxy prevents Squirrelmail 1.4.7 loading right_main.php

closed-fixed
Compose (426)
5
2006-07-25
2006-07-12
Skyjerk
No

squirrelmail 1.4.7 is on a system behind
an SSL proxy.

After clicking the send button in the compose window
it attempts to reload the frame with "right_main.php"
but it must be specifically asking for an absolute URL
starting with "http://"rather than a relative URL
and the frame gets loaded with an error screen saying

-------------------------------------------------------

"The requested URL /squirrelmail/src/right_main.php was
not found on this server.

Apache/1.3.34 Server at www.raventhorne.net Port 80"

--------------------------------------------------------

The "Port 80" is incorrect. The URL that accesses the
webmail is port 443

If I then hit the reload button on the browser it load
the page correctly.

I cant find the place in the code where it re-loads
that frame after sending a message so that I can fix it.

Discussion

<< < 1 2 (Page 2 of 2)
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2006-07-25

    Logged In: YES
    user_id=285765

    I've applied a bug fix to current devel and stable CVS that
    allows one to configure the proto+hostname+port part of the
    base uri (optionally), so situations like this where that
    goes wrong can then be fixed by the administrator. I think
    we cannot further improve our heuristic because some things
    we just don't know.

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2006-07-25
    • status: open --> closed-fixed
     
  • Nobody/Anonymous

    Logged In: NO

    os_shoman@aialight.com

     
<< < 1 2 (Page 2 of 2)

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks