#1929 Fix bug in SquirrelMail for IE7+

closed-fixed
nobody
5
2005-11-09
2005-10-27
Anonymous
No

This is verified in the latest stable source code
downloaded today:

In function SendDownloadHeaders:

Change:

if (strstr($HTTP_USER_AGENT, 'compatible; MSIE
6') !== false &&
strstr($HTTP_USER_AGENT, 'Opera') ===
false) {
$isIE6 = 1;
}

To:

Code which sets $isIE6 to any value 6 or higher for IE
version number.
Else the higher versions of IE will default to pre-IE6
behavior for this
script function, which is incorrect. Semantically, given
the use in the
function, it would be more clear to rename the $isIE6
variable to
$isIE6plus.

Discussion

  • Thijs Kinkhorst

    Thijs Kinkhorst - 2005-11-09

    Logged In: YES
    user_id=285765

    Fixed, thanks!

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2005-11-09
    • status: open --> closed-fixed
     

Log in to post a comment.