#1826 Doesn't display closing ) in From (1.4.x)

closed-fixed
nobody
5
2014-08-12
2005-07-20
No

A from header like this:

thijsk@isi.uu.nl (Thijs Kinkhorst (tkinkhor))

(it's real!) in the 1.4.x message list misses the last
")". It shows up like:

Thijs Kinkhorst (tkinkhor

Devel does this right, that shows:

Thijs Kinkhorst (tkinkhor)

Discussion

  • Jonathan Angliss

    Logged In: YES
    user_id=620333

    I think it does two things incorrectly. If you use the ( )
    which is a comment, but nothing else, it displays that in
    the From column, for example:

    From: <jon@squirrelmail.org> (test (123 test))

    This is displayed as:

    test (123 test

    In the folder tree, which I don't believe is correct. When
    you then select the message, the From field is displayed as:

    "test (123 test" <jon@squirrelmail.org>

    Which would also be incorrect. I need to double check the
    RFCs for the comment stuff to make sure we/I got the syntax
    correct.

    As another test, I put the comment stuff before the <email>
    and the result was different, and only the last ) was shown
    in the message list.

    The dev version seems to have the same issue and strips the
    "parent" () from around the string.

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2005-07-25

    Logged In: YES
    user_id=285765

    Well, devel works fine in my testcare though.

    Wouldn't it be a case of some regexp being not greedy enough?

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2006-06-26
    • status: open --> closed
     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2006-06-26
    • status: closed --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks