#1731 References Header

closed-fixed
None
5
2006-04-18
2005-03-21
Anonymous
No

Appears to only be in release 1.4.4.
Each reply to a message causes an addition Reference
Header entry.

For example: You email me, I reply.. You reply to my
reply, I reply to yours, etc... Eventually the IMAP
server error with: "Requested mail action aborted:
exceeding storage allocation
Server replied: 552 5.6.0 Headers too large (32768
max)" because of the quantity of reference headers.

This problem is new; only change was upgrade from
squirrelmail 1.4.3a to 1.4.4, so i'm guessing the IMAP
server is not to blame this time.

Discussion

  • Thijs Kinkhorst

    Thijs Kinkhorst - 2005-03-21

    Logged In: YES
    user_id=285765

    I cannot reproduce this in current stable. I also looked at
    the code that generates the References headers and it hasn't
    changed since 1.4.3a. Are you sure this is not a problem
    elsewhere?

     
  • Nobody/Anonymous

    Logged In: NO

    the only change that we have done is the squirrelmail
    upgrade, we're still running the same imap server (same
    version) same version of sendmail as well... Also no configs
    have been changed. I'll do a little more research and let
    you know if I find any more usefull information.

     
  • Nobody/Anonymous

    Logged In: NO

    Headers:

    Received: from XXXXXXXX.com (localhost [127.0.0.1])
    by www.XXXXXXXX.com (8.12.10/8.12.10) with ESMTP id
    j2LLfGa2009147
    for <XXXXXXXX@XXXXXXXX.com>; Mon, 21 Mar 2005 15:41:16
    -0600
    Received: from 72.18.172.71
    (SquirrelMail authenticated user XXXXXXX)
    by XXXXXXXX.com with HTTP;
    Mon, 21 Mar 2005 15:41:16 -0600 (CST)
    Message-ID: <4501.72.18.172.71.1111441276.squirrel@XXXXXXXX.com>
    In-Reply-To:
    <4501.72.18.172.71.1111441256.squirrel@XXXXXXXX.com>
    References: <4500.72.18.172.71.1111441093.squirrel@XXXXXXXX.com>
    <4501.72.18.172.71.1111441124.squirrel@XXXXXXXX.com>
    <4501.72.18.172.71.1111441150.squirrel@XXXXXXXX.com>
    <4501.72.18.172.71.1111441170.squirrel@XXXXXXXX.com>
    <4501.72.18.172.71.1111441190.squirrel@XXXXXXXX.com>
    <4501.72.18.172.71.1111441236.squirrel@XXXXXXXX.com>
    <4501.72.18.172.71.1111441256.squirrel@XXXXXXXX.com>
    Date: Mon, 21 Mar 2005 15:41:16 -0600 (CST)
    Subject: Re: test message
    From: "XXXXXXXX" <XXXXXXXX@XXXXXXXX.com>
    To: "XXXXXXXX" <XXXXXXXX@XXXXXXXX.com>
    User-Agent: SquirrelMail/1.4.4
    MIME-Version: 1.0
    Content-Type: text/plain;charset=iso-8859-1
    Content-Transfer-Encoding: 8bit
    X-Priority: 3 (Normal)
    Importance: Normal
    X-Spam-Checker-Version: SpamAssassin 2.63 (2004-01-11) on
    XXXXXXX
    X-Spam-Level: *
    X-Spam-Status: No, hits=1.2 required=5.0
    tests=BAYES_50,PRIORITY_NO_NAME
    autolearn=no version=2.63

    -- END OF HEADERS

    Message Body:

    7th reply

    > 6th reply
    >
    >> 5th reply
    >>
    >>> 4th reply
    >>>
    >>>> 3rd reply
    >>>>
    >>>>> 2nd reply
    >>>>>
    >>>>>> 1st reply
    >>>>>>
    >>>>>>> test message
    >>>>>>>
    >>>>>>>
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>>
    >>>>>
    >>>>>
    >>>>>
    >>>>
    >>>>
    >>>>
    >>>
    >>>
    >>>
    >>
    >>
    >>
    >
    >
    >
    -------
    I send myself an email and replied 7 times... this does not
    happen when using a client IMAP app :(

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2005-03-22

    Logged In: YES
    user_id=285765

    Ah, I think you don't understand the References header. It's
    supposed to have a list of all mails replied to. See RFC
    2822 section 3.6.4.

     
  • Nobody/Anonymous

    Logged In: NO

    Hmm... It's not a bug. Is There a simple way to disable the
    header within squirrelmail's config? Or does one have to
    directly modify the scripts?

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2005-03-23

    Logged In: YES
    user_id=285765

    You'll have to edit class/Deliver/Deliver.class.php

    I understand that you get problems with your SMTP server
    saying that your headers are too large? In that case we
    should look into limiting the size of the References header.
    Because it's true that there's no theoretical upper bound on
    its length now.

     
  • Marc Groot Koerkamp

    • status: open --> closed
     
  • Marc Groot Koerkamp

    Logged In: YES
    user_id=476981

    This is not a SquirrelMail bug but an issue with the SMTP
    server. Disabling reference headers is a feature rquest so I
    close this bug for now.

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2006-04-14
    • assigned_to: nobody --> kink
    • status: closed --> open
     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2006-04-18

    Logged In: YES
    user_id=285765

    I believe that the bug you reported has been fixed in the CVS version. Please either grab a live CVS version or wait and grab an archive of the CVS from tomorrow or later (just to make sure it has the changes in it).

    If the bug does not exist after you update to the CVS version, please close this bug report.

     
  • Thijs Kinkhorst

    Thijs Kinkhorst - 2006-04-18
    • status: open --> closed-fixed
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks