#883 DB2 Plugin no longer works after v3.0.3

3.1
closed-invalid
DB2 Plugin (16)
5
2010-06-23
2010-06-22
Quan Nguyen
No

DB2 Plugin no longer works after v3.0.3 on Windows XP. The IBM DB2 App Driver is shown not checked.

When I try to connect to a database, it generates the following error:

Could not find class COM.ibm.db2.jdbc.app.DB2Driver in neither the Java class path nor the Extra class path of the IBM DB2 App Driver driver definition:
java.lang.ClassNotFoundException: COM.ibm.db2.jdbc.app.DB2Driver

Loading JDBC driver "IBM DB2 App Driver" failed.
Can not load driver properties tab.

I even tried the db2.jar copied from the working version (3.0.3) into the plugins folder of the new version (3.1.1, 3.1.2), but it still did not help.

Discussion

  • Quan Nguyen

    Quan Nguyen - 2010-06-22
    • milestone: --> 3.1
     
  • Rob Manning

    Rob Manning - 2010-06-23

    It seems maybe you have confused the DB2 plugin with the DB2 JDBC driver. They serve different purposes and the DB2 plugin is only useful after you have installed the DB2 JDBC driver from your vendor (add it to SQUIRREL_INSTALL_FOLDER/lib and restart). Sorry, but we cannot legally ship the proprietary JDBC drivers - you must go to IBM and download that yourself.

    Rob

     
  • Rob Manning

    Rob Manning - 2010-06-23
    • status: open --> closed-invalid
     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks