#420 Squirrel does not run on JDK 6 (Mustang)

2.3rc1
closed-duplicate
Core (462)
5
2014-08-17
2006-09-10
Anonymous
No

Squirrel does not run on Mustang.

After creating an alias, the opening of the window
fails with an exception because the classloader code is
broken at
net.sourceforge.squirrel_sql.fw.util.Utilities$1.resolveClass

java version "1.6.0-rc"
Java(TM) SE Runtime Environment (build 1.6.0-rc-b96)
Java HotSpot(TM) Server VM (build 1.6.0-rc-b96, mixed mode)

java.lang.RuntimeException:
java.lang.ClassNotFoundException:
[Lnet.sourceforge.squirrel_sql.client.gui.db.SQLAliasSchemaDetailProperties;
at
net.sourceforge.squirrel_sql.fw.util.Utilities.cloneObject(Utilities.java:351)
at
net.sourceforge.squirrel_sql.client.gui.db.SQLAlias.assignFrom(SQLAlias.java:150)
at
net.sourceforge.squirrel_sql.client.session.Session.<init>(Session.java:195)
at
net.sourceforge.squirrel_sql.client.session.SessionManager.createSession(SessionManager.java:135)
at
net.sourceforge.squirrel_sql.client.mainframe.action.ConnectToAliasCommand$SheetHandler.createSession(ConnectToAliasCommand.java:349)
at
net.sourceforge.squirrel_sql.client.mainframe.action.ConnectToAliasCommand$SheetHandler.run(ConnectToAliasCommand.java:313)
at
net.sourceforge.squirrel_sql.fw.util.TaskExecuter.run(TaskExecuter.java:82)
at java.lang.Thread.run(Thread.java:619)
Caused by: java.lang.ClassNotFoundException:
[Lnet.sourceforge.squirrel_sql.client.gui.db.SQLAliasSchemaDetailProperties;
at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
at java.security.AccessController.doPrivileged(Native
Method)
at
java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at
sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:276)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at
net.sourceforge.squirrel_sql.fw.util.Utilities$1.resolveClass(Utilities.java:340)
at
java.io.ObjectInputStream.readNonProxyDesc(ObjectInputStream.java:1575)
at
java.io.ObjectInputStream.readClassDesc(ObjectInputStream.java:1496)
at
java.io.ObjectInputStream.readArray(ObjectInputStream.java:1624)
at
java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1323)
at
java.io.ObjectInputStream.defaultReadFields(ObjectInputStream.java:1945)
at
java.io.ObjectInputStream.readSerialData(ObjectInputStream.java:1869)
at
java.io.ObjectInputStream.readOrdinaryObject(ObjectInputStream.java:1753)
at
java.io.ObjectInputStream.readObject0(ObjectInputStream.java:1329)
at
java.io.ObjectInputStream.readObject(ObjectInputStream.java:351)
at
net.sourceforge.squirrel_sql.fw.util.Utilities.cloneObject(Utilities.java:344)
... 7 more

Discussion

  • Rob Manning

    Rob Manning - 2006-09-10

    Logged In: YES
    user_id=1287991

    Thanks for reporting it, but it's an old bug see here:

    http://sourceforge.net/support/tracker.php?aid=1448738

    I've filed a bug report against JDK 6.0 for this issue
    (For more details, see the link above)

    Rob

     
  • Rob Manning

    Rob Manning - 2006-09-10
    • assigned_to: colbell --> manningr
    • status: open --> closed-wont-fix
     
  • Rob Manning

    Rob Manning - 2006-09-10
    • status: closed-wont-fix --> closed-duplicate
     
  • Rob Manning

    Rob Manning - 2006-09-10

    Logged In: YES
    user_id=1287991

    OK, so I just went back and read the evaluation given for the
    bug report I filed with Sun and it appears there is a fix
    which is permanent, that I have tested and will become
    available in the next snapshot. See the original SQuirreL
    bug (1448738) where I'll detail the fix that was implemented.

    Rob Manning

     

Log in to post a comment.