#372 General loss of responsiveness

2.1final
closed
Core (461)
9
2006-05-31
2006-04-06
No

This error occurrs with SQuirrel SQL Client Version
2.1 final. To resolve the problem I have tried
upgrading from jdk1.5.0_04 to jdk1.5.0_06, which did
not help.

All aspects of the SQuirrel SQL GUI looses
responsiveness, meaning that the results of any
mouseclick or keypress needs from 1-10 seconds before
the results comes. This bug makes SQuirrel totally
hopeless to use. The error occurs only occasionally,
and I have not yet found any system in when the bug
occurres. It does not help to restart SQuirrel, it is
irrelevant whether I am connected to a database or
not. The error does not occur to JVM in general,
because Eclipse can function as normal while the
error is occurring in SQuirrel SQL.

I will try to get back to you, if I discover a
pattern when the bug occurres.

Discussion

  • David Andersen

    David Andersen - 2006-04-06

    Logged In: YES
    user_id=1084621

    It should also be said that I am running Windows XP SP2. I
    don't know if it is relevant, but my computer is running a
    resolution of 1900x1200.

     
  • David Andersen

    David Andersen - 2006-04-06
    • priority: 5 --> 9
     
  • Rob Manning

    Rob Manning - 2006-04-06
    • assigned_to: colbell --> manningr
     
  • Rob Manning

    Rob Manning - 2006-04-06

    Logged In: YES
    user_id=1287991

    Perhaps you'll want to try 2.2 RC1. It has some changes
    designed to address the resposiveness of the app (especially
    when you are connecting to a large database and/or using a
    small pipe - like vpn). Let us know what you think.

     
  • David Andersen

    David Andersen - 2006-04-06

    Logged In: YES
    user_id=1084621

    I will try that, but I believe that there is something
    fundamentally wrong, since even to scroll a resultset 20
    items takes 3 seconds to calculate.

     
  • Rob Manning

    Rob Manning - 2006-04-06

    Logged In: YES
    user_id=1287991

    "since even to scroll a resultset 20 items takes 3 seconds
    to calculate"

    The only time I've seen this particular problem is when one
    of the columns was a BLOB and non-null. We attempt to render
    the blob data (in hexadecimal format) and I believe we are
    not truncating it, so scrolling becomes very slow and
    unresponsive. Does the table that you are attempting to
    scroll a resultset for have a BLOB column?

    Rob

     
  • David Andersen

    David Andersen - 2006-04-06

    Logged In: YES
    user_id=1084621

    No, and I can say that even typing the letter "a" or "b"
    in the sql query text box takes one second to process. It
    is a GENERAL loss of responsiveness. No matter what action
    I perform, it takes at least one second to process.

     
  • Gerd Wagner

    Gerd Wagner - 2006-04-06

    Logged In: YES
    user_id=776065

    I once heard about performance problems, though never as bad
    as yours, related to look and feels. You may try a Metal
    look and feel and see if it changes the behavior.

    It might be worth having a look at your system too. How do
    other Java/Swing apps perform? At my workplace several
    people including myself use Windows XP SP2 and have never
    experienced such problems.

     
  • Nobody/Anonymous

    Logged In: NO

    It seems like it did the trick. Thanks! I will get back to
    you if the problem arises again.

     
  • Gerd Wagner

    Gerd Wagner - 2006-04-08

    Logged In: YES
    user_id=776065

    I'm glad it helped. I'll close this bug for now.

     
  • Gerd Wagner

    Gerd Wagner - 2006-04-08
    • status: open --> closed
     
  • David Andersen

    David Andersen - 2006-04-28

    Logged In: YES
    user_id=1084621

    I am sorry to disappoint you, but after further testing, I
    have noticed that the problem still exists, even if I
    change L&F to Metal. Do you have any other ideas?

     
  • David Andersen

    David Andersen - 2006-04-28
    • status: closed --> open
     
  • Gerd Wagner

    Gerd Wagner - 2006-05-01

    Logged In: YES
    user_id=776065

    I'm sure that it isn't a general problem because the
    platform you use is quite common. In fact I use it myself at
    work.

    Since I can't reproduce your problem the only thing I can do
    is to ask you is to help figuring it out. At
    http://squirrelsql.org/index.php?page=programing
    you can find an introduction how to work with SQuirreL's
    source code. Perhaps you could find out some details about
    your problem.

    I'm sorry I can't offer more.

     
  • David Andersen

    David Andersen - 2006-05-02

    Logged In: YES
    user_id=1084621

    Thanks for your reply Gerdwagner. As I am really under
    pressure at the moment, I won't be able to get into the
    sourcecode to debug myself. I will try to get back to you
    after my deadline.

     
  • Gerd Wagner

    Gerd Wagner - 2006-05-16
    • status: open --> pending
     
  • Gerd Wagner

    Gerd Wagner - 2006-05-16

    Logged In: YES
    user_id=776065

    Setting this bugs state to pending.

     
  • SourceForge Robot

    • status: pending --> closed
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks