#318 Not possible to edit data after SQL query

2.1final
closed-fixed
9
2006-09-28
2005-12-02
VAdamec
No

I'm using mysql-connector v3.1.12, rc2 SQuirrel and I
can't edit data from SQL query - simple select (select
* from <unique_table_name>). I could edit data only
from main session screen (there is 'Make Ediatable' in
menu in SQL not). Database is MySQL 4.1.14. Tested on
Win XP Pro and SuSe Linux.

Discussion

1 2 > >> (Page 1 of 2)
  • Rob Manning

    Rob Manning - 2005-12-02
    • labels: 336290 --> 404491
    • assigned_to: colbell --> nobody
     
  • Rob Manning

    Rob Manning - 2005-12-02

    User VAdamec's log file with exceptions

     
  • VAdamec

    VAdamec - 2005-12-02
    • summary: Not possible to edit data after SQL query --> Not possible to edit data after SQL query
     
  • VAdamec

    VAdamec - 2005-12-02

    Logged In: YES
    user_id=1292032

    Tested with MS-SQL database - there is editation is
    possible, so only MySQL is problematic.

     
  • VAdamec

    VAdamec - 2006-01-05

    Logged In: YES
    user_id=1292032

    Nobody have same problem with MySQL? It is mysql connector
    problem (3.1.8 v. used)? 2.1 final still same problem - no
    item "Make editable" in menu after SQL query.

     
  • VAdamec

    VAdamec - 2006-01-05

    Logged In: YES
    user_id=1292032

    In Session properties-General is section Output, "SQL
    results" and "Table Contents" are Set Up to "Editable Table"
    but works only for "Table Contents". Same result with older
    MMSQL and newest mysql connector 3.1.12. Works with MS SQL
    database. Log is attach.

     
  • VAdamec

    VAdamec - 2006-01-05
    • labels: 404491 --> MySQL Plugin
     
  • VAdamec

    VAdamec - 2006-01-05
    • assigned_to: nobody --> manningr
    • milestone: 543705 --> 2.1final
    • priority: 5 --> 9
     
  • VAdamec

    VAdamec - 2006-01-05

    2.1 final

     
  • Rob Manning

    Rob Manning - 2006-01-13

    Logged In: YES
    user_id=1287991

    I think I managed to reproduce the issue (or perhaps a
    related one.) Steps to follow:

    1. Create a user and two database catalogs.
    2. Give the user access to both catalogs.
    3. Login as the user using catalog "A" in the connect url:

    jdbc:mysql://localhost:3306/A

    4. Create a table in catalog B like:

    create table B.test ( id integer);

    5. Insert some data into B.test:

    insert into table B.test values (1);

    6. Select data in the SQL pane from B.test:

    select * from B.test;

    7. Right-click on the results table and select "Make Editable"

    8. Try to change the value to 2 and press enter.

    9. Notice an error dialog stating that the table could not
    be found.

    Rob Manning

     
  • Rob Manning

    Rob Manning - 2006-01-14

    Logged In: YES
    user_id=1287991

    I think I managed to reproduce the issue (or perhaps a
    related one.) Steps to follow:

    1. Create a user and two database catalogs.
    2. Give the user access to both catalogs.
    3. Login as the user using catalog "A" in the connect url:

    jdbc:mysql://localhost:3306/A

    4. Create a table in catalog B like:

    create table B.test ( id integer);

    5. Insert some data into B.test:

    insert into table B.test values (1);

    6. Select data in the SQL pane from B.test:

    select * from B.test;

    7. Right-click on the results table and select "Make Editable"

    8. Try to change the value to 2 and press enter.

    9. Notice an error dialog stating that the table could not
    be found.

    Rob Manning

     
  • Rob Manning

    Rob Manning - 2006-01-15
    • status: open --> closed-duplicate
     
  • Nobody/Anonymous

    Logged In: NO

    IMHO it is not same as bug 1250514 - because in this bugs
    is, at least, ¨Make Editable¨ item in left-click menu. But
    I haven´t got this in menu (only in Session Properties).

     
  • Rob Manning

    Rob Manning - 2006-01-16

    Logged In: YES
    user_id=1287991

    Ok, we'll leave it open then ;)

    You are correct, it is a slightly different problem. If you
    had a "Make Editable" item in your context menu, then the
    other bug might be exposed.

    Rob

     
  • Rob Manning

    Rob Manning - 2006-01-16
    • status: closed-duplicate --> open
     
  • VAdamec

    VAdamec - 2006-01-19

    Logged In: YES
    user_id=1292032

    Items in menu depend on driver which is used or it is affect
    by other part of squirrel? I found only one mysql driver -
    mysql connector, could I try another driver (if exist)?

     
  • Rob Manning

    Rob Manning - 2006-01-19

    Logged In: YES
    user_id=1287991

    VAdamec,

    I don't think that menu is driver-specific.

    So what is it exactly that you see when you right-click on
    the result tab from a SQL query? If I understand you
    correctly it is apparently not a menu with the following
    options:

    Copy
    Copy as HTML
    Copy as SQL IN Statement
    ---
    Make Editable
    ---
    Select All
    ---
    Print

    If that is the case, what is in the right-click menu?
    A screenshot might be useful too!

    Rob

     
  • VAdamec

    VAdamec - 2006-01-19
     
  • VAdamec

    VAdamec - 2006-01-19

    Logged In: YES
    user_id=1292032

    Here is screenshot

     
  • Rob Manning

    Rob Manning - 2006-01-19

    Logged In: YES
    user_id=1287991

    Beautiful! That picture is very helpful. It is pretty
    much what I had imagined based on your previous posts.
    I'll look into it, and let you know what I find.

    Rob

     
  • Rob Manning

    Rob Manning - 2006-01-22

    Logged In: YES
    user_id=1287991

    What does your query look like? (certain joins preclude
    editing the result data)

    Rob

     
  • Nobody/Anonymous

    Logged In: NO

    it is simple select, select * from ´table´ where ´something
    ´ LIKE ´text´. And the tested database is simple too, one
    db with one table.

     
  • Rob Manning

    Rob Manning - 2006-04-12
    • status: open --> pending-works-for-me
     
  • Rob Manning

    Rob Manning - 2006-04-12

    Logged In: YES
    user_id=1287991

    It seems that no matter what I try, I cannot reproduce this
    problem. Anything else you can tell me about the data
    would be appreciated. Perhaps a table def and some insert
    statements that produce data that I can use to reproduce the
    problem would be helpful. We will be release 2.2 final soon
    and I'd like to resolve this if at all possible. But if I
    cannot reproduce it, there is no hope that I will find the
    cause.

    Rob

     
1 2 > >> (Page 1 of 2)

Log in to post a comment.