#313 JDK 1.3 throws UnsupportedClassVersionError (major.minor 48)

2.1rc1
closed-wont-fix
None
5
2005-11-15
2005-11-15
Anonymous
No

Installer fails when using JDK 1.3:

java version "1.3.1_14"
Java(TM) 2 Runtime Environment, Standard Edition (build
1.3.1_14-b03)
Java HotSpot(TM) Client VM (build 1.3.1_14-b03, mixed
mode)

Exception in thread "main" java.lang.
UnsupportedClassVersionError: com/izforge/izpack/
installer/Installer (Unsupported major.minor version 48.0)
at java.lang.ClassLoader.defineClass0(Native
Method)
at java.lang.ClassLoader.defineClass(ClassLoader.
java:488)
at java.security.SecureClassLoader.
defineClass(SecureClassLoader.java:106)
at java.net.URLClassLoader.
defineClass(URLClassLoader.java:243)
at java.net.URLClassLoader.
access$100(URLClassLoader.java:51)
at java.net.URLClassLoader$1.
run(URLClassLoader.java:190)
at java.security.AccessController.
doPrivileged(Native Method)
at java.net.URLClassLoader.
findClass(URLClassLoader.java:183)
at java.lang.ClassLoader.loadClass(ClassLoader.
java:294)
at sun.misc.Launcher$AppClassLoader.
loadClass(Launcher.java:288)
at java.lang.ClassLoader.loadClass(ClassLoader.
java:250)
at java.lang.ClassLoader.
loadClassInternal(ClassLoader.java:310)

Discussion

  • Rob Manning

    Rob Manning - 2005-11-15

    Logged In: YES
    user_id=1287991

    From the "Overview":

    "SQuirreL SQL Client is a graphical Java program that will
    allow you to view the structure of a JDBC compliant
    database, browse the data in tables, issue SQL commands etc.
    The minimum version of Java supported is 1.4.x. See the Old
    Versions page for versions of SQuirreL that will work with
    older versions of Java."

    JDK 1.3 isn't supported for use with 2.1rc1

    Rob Manning

     
  • Rob Manning

    Rob Manning - 2005-11-15
    • status: open --> closed
     
  • Rob Manning

    Rob Manning - 2005-11-15
    • assigned_to: nobody --> manningr
    • status: closed --> closed-wont-fix
     

Log in to post a comment.