#283 Oracle DATE does not display correctly

2.3rc2
closed-fixed
Core (462)
5
2006-09-23
2005-08-03
amr roushdi
No

Oracle date seems that it does not display properly it
displays only the date without hours&seconds .
In DB2 I get the correct format fully displayed

thanks agin for this product .
aroushdi

Discussion

  • amr roushdi

    amr roushdi - 2005-08-03

    Logged In: YES
    user_id=564324

    This happens also in sqlexplorer for eclipse

     
  • Rob Manning

    Rob Manning - 2005-08-05

    Logged In: YES
    user_id=1287991

    Perhaps a configuration in Global Preferences should allow
    the user
    to to specify date format yyyy:mm:day hh:ss.
    This seems like a valid issue to me.

    Rob

     
  • Gerd Wagner

    Gerd Wagner - 2006-02-15
    • status: open --> closed
     
  • Gerd Wagner

    Gerd Wagner - 2006-02-15

    Logged In: YES
    user_id=776065

    We could not reproduce the problem. Rob's hint should work.
    Will be closed.

     
  • Gerd Wagner

    Gerd Wagner - 2006-02-15

    Logged In: YES
    user_id=776065

    We could not reproduce the problem. Rob's hint should work.
    Will be closed.

     
  • Rob Manning

    Rob Manning - 2006-09-22

    Logged In: YES
    user_id=1287991

    Gerd,

    I'm going to re-open this as I see how we can easily
    support displaying Oracle DATEs with their time component.
    I'll add a way to make this configurable to get either the
    new or old behavior.

    Rob

     
  • Rob Manning

    Rob Manning - 2006-09-22
    • assigned_to: colbell --> manningr
    • status: closed --> open
     
  • Rob Manning

    Rob Manning - 2006-09-23
    • milestone: --> 2.3rc2
    • status: open --> closed-fixed
     
  • Rob Manning

    Rob Manning - 2006-09-23

    Logged In: YES
    user_id=1287991

    The problem has to do with the fact that Oracle DATE columns
    are really implemented as TIMESTAMPS. They can hold both
    the date and time components. JDBC (ResultSet.getDate)
    treats the DATE column as if it only holds the date
    component - the time component is lost. This makes sense
    from an SQL standards viewpoint. For whatever readon
    Oracle chose to make DATE synonymous with TIMESTAMP. So
    to support that capability, I added a configuration item
    to Global Preferences -> Date Type Controls -> Date Section
    which allows the user to "Interpret DATE columns as
    TIMESTAMP". JDBC allows the DATE column data to be
    accessed via ResultSet.getTimestamp(), so this
    configuration takes advantage of that and seems to cause
    no harm in other databases that I've tested it with (
    Time component appears as 00:00:00 when used with DATE
    columns that don't contain the time component).
    Fixed in CVS.

    Rob

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks