Sorry, forgot to add this. A relevant traceback:

Exception in thread Thread-2:
Traceback (most recent call last):
  File "/usr/lib/python2.6/", line 525, in __bootstrap_inner
  File "/usr/lib/python2.6/", line 477, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/home/godlike/indexor/indexor/logic/input/", line 285, in do_index_process
    self.parse_size(size), absname)
  File "/home/godlike/indexor/indexor/logic/input/", line 73, in new_dir
    connection = self._conn)
  File "/usr/local/lib/python2.6/dist-packages/sqlobject/", line 1211, in __init__
    if self._connection is not connection:
  File "/usr/local/lib/python2.6/dist-packages/sqlobject/", line 837, in __get__
    return self.getConnection()
  File "/usr/local/lib/python2.6/dist-packages/sqlobject/", line 850, in getConnection
    "No connection has been defined for this thread "
AttributeError: No connection has been defined for this thread or process

On Thu, Apr 8, 2010 at 6:47 PM, Juan Manuel Santos <> wrote:
Hello again list,

I've been testing a program I'm coding on gentoo (SQLObject 0.11) on Ubuntu/Debian. I tried both with older SQLObject (0.10 IIRC) and also current SVN. But I'm getting the same error from the subject line.

I currently can't paste a code example, but it is worth noting that I don't set any connection globally (since my plans are for the application to be able to manage several connections to different databases at the same time). Instead, I pass a connection parameter to every select, class creation and any SQLObject method which may require it.

On Gentoo this behaviour does not get triggered at all. Any ideas as to why this could be happening?

Juan Manuel Santos