Sorry about the top-post.

I am using SQLObject 0.10dev-r3137 installed from an egg.

Even with the charset set to utf8 I still get the same error. I must be on an older version. I will update and let you know.


On Jan 4, 2008 4:21 PM, Oleg Broytmann <phd@phd.pp.ru> wrote:
Please, do not top-post.

On Fri, Jan 04, 2008 at 04:15:09PM -0500, Glenn MacGregor wrote:
> Looking into this issue a bit more revealed that in the StringValidator
> class, line 505 on col.py, the from_python function tries to encode all
> unicode type strings to ascii. Is this correct behavior? If so how can I get
> around it ?

  What version of SQLObject? In the latest version the encoding is not
'ascii' - the code is

           dbEncoding = getattr(connection, "dbEncoding", None) or "ascii"

  so to change the encoding (on MySQL) you have to set it in the DB URI:


    Oleg Broytmann            http://phd.pp.ru/             phd@phd.pp.ru
          Programmers don't die, they just GOSUB without RETURN.

This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
sqlobject-discuss mailing list