Erreurs in PHP5

Help
chatlumo
2004-08-14
2004-08-15
  • chatlumo

    chatlumo - 2004-08-14

    Bonsoir,

    Avec PHP5, voil les erreurs affiches sur l'index.php :

    Strict Standards: var: Deprecated. Please use the public/private/protected modifiers in C:\Program Files\Apache Group\Apache2\htdocs\SQLiteManager\include\SQLite.i18n.php on line 24

    Strict Standards: Assigning the return value of new by reference is deprecated in C:\Program Files\Apache Group\Apache2\htdocs\SQLiteManager\include\SQLite.i18n.php on line 69

    Strict Standards: Assigning the return value of new by reference is deprecated in C:\Program Files\Apache Group\Apache2\htdocs\SQLiteManager\include\common.lib.php on line 240

     
    • HENNINOT frederic

      Bonsoir!
      La version 0.9.8-1 publi le 13/08 doit corrig ce problme!
      Merci de me tenir inform si ce n'est pas le cas!
      Fred

       
    • chatlumo

      chatlumo - 2004-08-15

      J'ai bien cette dernire version malheureusement :(

      L'avez-vous test avec PHP5 version finale ?

       
    • HENNINOT frederic

      oui bien sur et mme avec la 5.0.1!
      Il semble que le probleme provienne d'un bug de PHP5! je viens de soumettre un rapport de bug!
      Je te conseille de supprimer le 'E_STRICT' du 'error_reporting' dans le fichier php.ini
      Il n'est pas possible de d'activer/dsactiver cette option dans le code; ce qui est un problme pour la compatibilit avec PHP4
      Fred

       
    • HENNINOT frederic

      heu dsol!!
      Faut juste que j'arrete de fumer la moquette!!
      Je viens de publier une nouvelle version!!
      A+

       
      • chatlumo

        chatlumo - 2004-08-15

        C'est ok maintenant ;)

        Merci !

         

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks