#33 unable to open tcx files


I tried it under Windows 7and Kubuntu 10.4.
Whenever I open a tcx file I get an error that the file could not be read or parsed. I also tried the samplefiles from http://developer.garmin.com/schemas/tcx/v2/

But I will also attach my file. The tcx file is to large, so I will attach the gpx file, you can convert it to tcx here: http://www.gpsies.com/convert.do



  • jede28

    jede28 - 2010-07-16
    • status: open --> pending
  • jede28

    jede28 - 2010-07-16

    Hi Mr. Unkown,

    SportsTracker only supports TCX files created by Garmin Edge or ForeRunner devices, such as Edge 705 or 500.
    There are a lot of converters out there which claim to produce valid TCX files, but there's often missing data in the converted files. I think that's why it fails in your case.
    You need to attach the original TCX file to this bug, the converted GPX file does not help.

    BTW, GPX files will be supported in the future.

    Bye, Stefan

  • jede28

    jede28 - 2010-07-20

    Please attach the original TCX file, if there is one. Otherwise I assume that it was a TCX file created by a converter.
    Then this bug would be invalid, I would need to close iit.

    Bye, Stefan

  • jede28

    jede28 - 2010-07-23

    Can't be fixed without the original TCX file. As I've already said, it's probably a converted one, these are not supported.

  • jede28

    jede28 - 2010-07-23
    • status: pending --> closed-invalid

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks