SourceForge has been redesigned. Learn more.

2.0.0 RC results CLP-500 - 1200 DPI Poor

  • Roger Hardiman

    Roger Hardiman - 2008-06-30

    I installed Splix 2.0.0 RC2 on Fedora 9 and printed some test pages on my CLP-500

    600 DPI - looked OK.
    Full A4 page displayed. Error diffusion (dithering) on the Grey ramp.

    1200x600 DPI - prints the page Twice as Wide.
    So the scale along the top goes from 1cm up to 10cm. The Title "Printer Test Page" jusrt says "Printer T" and then it reaches ther right hand edge.

    1200 DPI - strange colours in the colour wheel.
    There are bits of yellow bear the centre of the red, green, blue and cyan coour segments.
    Full A4 page displayed

    I'm happy to test fixes in SVN if there are any available.

    Roger Hardiman

    • Konstantin Mazumoto

      Hi Roger,

      did you do any magic to make the driver work for your CLP-500 ? As I posted on the mailing list already, the driver doesn't work for me with the message "SpliX Cannot read pixel line". Actually it seems there is a segfault involved: "PID 5946 (/usr/libexec/cups/filter/pstoraster) crashed on signal 11!".
      Did you by chance run into similar problems ?


    • Roger Hardiman

      Roger Hardiman - 2008-07-10

      Hi Konstantin,
      I did not do any magic to make the driver work with mu CLP-500.
      I did the following
      new install of Fedora 9 with all the updates applied
      installed splix 1.1.x. Printing worked fine.
      compiled splix 2.0.0rc2, installed. In CUPS removed the printer and added the new V2.0.0 printer
      And it all worked fine
      Then I remembered to add the CMS files.
      I did not have to change any file permissions or change any config files

    • Konstantin Mazumoto

      Just a short note if somebody runs into a similar problem as I:

      Not splix but ghostscript was the problem - I had an old version of it (ghostscript-esp-8.15.4). ghostscript got merged after that version to ghostscript-gpl. Version 8.62 works fine for me.

      Thanks, Roger, for getting me on the right track !

      My colour results seem to be the same as for Roger, an okay looking testpage for 600x600dpi (but photos look washed out, like old 16 colour gifs) and looking a lot worse for 1200x1200dpi (like too high contrast setting for photos).

    • |-|ans

      |-|ans - 2009-04-12

      Well, in fact photo / graphics printing results are poor in all situations. The colors really look awful, and printing photos is really not done. Except from that, it IS working and that is a great starting point.

      I also noticed Samsung still supports this printer in its later proprietary driver (the 3 version) which can be downloaded by selecting a different printer model. And, although just 600 dpi, photos DO look better using that driver. Well, at least the colors do.

      But still it seems the only way to get an impressive color print is to press the DEMO button :(

      And of course I do also lack the booklet print option, which was very frequently used by me, but that is of course no real "complaint" since even Samsung does not support the function with its own Linux driver... However: now that I have really abandoned windoze it IS something that is missed ;)

    • Aurélien Croc

      Aurélien Croc - 2009-04-12

      I'm pretty sure that there is a problem with the color profiles. Please set the LogLevel to debug in the cupsd.conf, relaunch cups, print something and send to me the /var/log/cupsd/error_log file.

      But before, please make sure that you have installed the color profile (as described at the end of the INSTALL file)



Log in to post a comment.