• Anonymous - 2012-05-27


    Does this printer work with the latest svn? I tried the Ubuntu driver:


    But they doesn't work. Can I help to supporting this printer?

  • Anonymous - 2012-05-28


    With the ML-1640 Splix driver I get this Error Page:

    INTERNAL ERROR - Please use the proper driver

    POSITION : 0x0 (0)

    SYSTEM : h6fw_5.49/xl_op

    LINE : 180

    VERSION SPL 5.49 10-20-2010

  • Anonymous - 2012-05-28


    I tried to compile the latest svn with Ubuntu 12.04.

    $ make
         CXX               src/rastertoqpdl.cpp
         CXX               src/request.cpp
         CXX               src/printer.cpp
         CXX               src/qpdl.cpp
         CXX               src/document.cpp
    src/document.cpp: In Elementfunktion »Page* Document::getNextRawPage(const Request&)«:
    src/document.cpp:83:10: Warnung: »unsigned int cupsRasterReadHeader(cups_raster_t*, cups_page_header_t*)« ist veraltet (deklariert bei /usr/include/cups/raster.h:370)
    src/document.cpp:83:47: Warnung: »unsigned int cupsRasterReadHeader(cups_raster_t*, cups_page_header_t*)« ist veraltet (deklariert bei /usr/include/cups/raster.h:370)
    src/document.cpp:70:19: Warnung: Variable »documentWidth« gesetzt, aber nicht verwendet
         CXX               src/core.cpp

  • Leonardo Hamada

    Leonardo Hamada - 2012-06-01


    Compiling will warn on some depreciated cups functions but it should be o.k.

    Perhaps it could be interesting to follow the user bugs tracker  #3518684 "ML-2540 (QPDL-5) does NOT work - prints INTERNAL ERROR"

    Good luck.

  • Anonymous - 2012-06-02

    It works with the CLP-310 driver! Setting must be monocrome instead of color.

  • Anonymous - 2012-06-09

    After a few tests with the CLP-310 driver:

    600dpi is working
    1200dpi is not working (only a lot of dots on the page)


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks