#101 Cannot use " in subject

closed
Posting (28)
9
2006-04-01
2005-11-12
No

Try using " in the subject of a blog entry. Pressing
"preview" makes all text in the subject after (and
including) the " sign disappear.

Discussion

  • Jan Normann Nielsen

    • labels: --> Posting
     
  • Rafael Rivera

    Rafael Rivera - 2005-11-15

    Logged In: YES
    user_id=740565

    Use " instead for now.

     
  • Bill Bateman

    Bill Bateman - 2005-11-16

    Logged In: YES
    user_id=1338564

    I just tried it with 0.4.6.1 and it worked fine with noth
    single and double quotes. Have you tried it lately?

     
  • Bill Bateman

    Bill Bateman - 2005-11-22
    • status: open --> closed
     
  • Jan Normann Nielsen

    • status: closed --> open
     
  • Jan Normann Nielsen

    Logged In: YES
    user_id=671213

    The bug is still in 0.4.6.1!

    When using " in the subject, press preview. Then all text
    after and including " disappears from the "Subject" edit box.

     
  • Bill Bateman

    Bill Bateman - 2006-02-06
    • assigned_to: nobody --> apalmo
     
  • Bill Bateman

    Bill Bateman - 2006-02-06
    • priority: 5 --> 9
     
  • Jan Normann Nielsen

    Logged In: YES
    user_id=671213

    The problem is in sb_forms.php where quotes in HTML
    attributes are not encoded. Line 93 reads:

    $str .= ' value="'.$value.'"';

    This should be:

    $str .= ' value="'.str_replace('"', '"', $value).'"';

    In fact, it should be so everywhere an attribute for a HTML
    element is rendered all through the blog.

     
  • Bill Bateman

    Bill Bateman - 2006-03-18

    Logged In: YES
    user_id=1338564

    I am working on this one, but when implemented, it opens up
    a whole new can of whoopa** on other parts of the code
    (including actually showing the &quot instead of the " in
    the preview screen (works fine in the main listing).

    I will continue to look into this issue.

    Bill

     
  • Bill Bateman

    Bill Bateman - 2006-03-18
    • assigned_to: apalmo --> bbateman
     
  • Bill Bateman

    Bill Bateman - 2006-03-18

    Logged In: YES
    user_id=1338564

    Alex put in a code change for this matter. Please retest in
    0.4.7.2.

    Bill

     
  • Bill Bateman

    Bill Bateman - 2006-03-18
    • status: open --> pending
     
  • SourceForge Robot

    Logged In: YES
    user_id=1312539

    This Tracker item was closed automatically by the system. It was
    previously set to a Pending status, and the original submitter
    did not respond within 14 days (the time period specified by
    the administrator of this Tracker).

     
  • SourceForge Robot

    • status: pending --> closed
     

Log in to post a comment.