How to play Speed Dreams?

  • cyberpatrol

    cyberpatrol - 2011-08-18

    Ok, I just came across Speed Dreams and tried it out. But… How do I play this? I mean if I press the Up arrow on the keyboard in a racing game the car usually drives forward and if I press the Down arrow it brakes or drives backward. Both is done in Speed Dreams, too. But, how do I steer? Usually if I press the Left arrow the car drives to the left, and if I press the Right arrow it drives to the right. But in Speed Dreams nothing happens. And if I move the mouse it just spins. So no usual contol is possible.

    So how do I play it and is there a real documentation about this game?

  • Jean-Philippe Meuret

    Hi, Cyberpatrol, and welcome !

    If you are running Speed Dreams on Windows after installing it from a binary package/distribution, you should have a "How to drive" or "Help" (or so) shortcut in your Speed Dreams startup menu.

    If you built it from sources, simply open the <sources>/doc/userman/how_to_drive.html file.

    Otherwise, or in any case, you can download the "How to drive" documentation from the SVN repository here :<your version>/doc/userman
    (through the download GNU tarball link at the bottom of the page).
    And then extract everything from the tar ball on your disk and open the doc/userman/how_to_drive.html file.

    We don't have on-line documentation yet … may be we'll put it online for the 2.0.0 release.

  • cyberpatrol

    cyberpatrol - 2011-08-18

    Thanks for the info.

    I'm using Arch Linux. Unfortunately the speed-dreams package doesn't include the documentation. I filed a feature request to the downstream maintainer.

    But it doesn't help regarding my control issue. I guess there's a bug in the game. No matter if I'm using the keyboard or the mouse the car just spins. It's absolutely not possible to control and drive it.

    I tried TORCS and there I can control the car even if I have the impression that it reacts pretty slowly and inaccurate.

  • Jean-Philippe Meuret

    The Linux binary packages don't include the documentation we have because we don't "install" it … not an Arch Linux issue, an SD build system issue we have to do something to fix.

    About the car controlability, it depends heavily on the car set, on the specific car in the car set, and also on the actual release you are testing.

    In 1.4.0, the LS1 and 36GP cars are very difficult to driver without wheel/pedals.

    In the 2.0.0.alpha series, we have been working hard on the realism of the physics, thus changing the physics engine (a new Simu v2.1 is born) and then the car baseline setups.
    I don't remember about alpha1, but IRRC, alpha2 was pretty like 1.4.0, but with easier LS1 behaviour.

    As for Alpha 3, the LS1 are pretty undrivable. But you can simply overwrite the XML files of the cars of your alpha3 installation with the ones you can find here, in the ls1-* folders : (and same for the 36GP) : we have made good progress on this LS1 and 36 GP baseline setup side, except for the ls1-cavallo-570s1, which is not finished. The old TRB1 are quite easy to control, as well as the MP5. As for the robots setups, only the TRB1 setups should work relatively well, seems it is not the case for the Supercars (BTW, USR seems to do better that Simplix here) and the other car sets need at least some rework.

    And don't forget to use TCS, it helps a lot (even if you can enjoy Andrew's last and killing improvements, unless you build from sources). And to start in the "Rookie" skill level, it can help.

    Hope this helps.

  • cyberpatrol

    cyberpatrol - 2011-08-18

    Arch Linux doesn't use your binary package. The Arch Linux maintainers compile every package themselves, similar to Gentoo except that the compilation doesn't need to be done by every single user. They can easily copy the documentation from your source package to the Arch Linux binary package. So it's an Arch Linux issue. ;-)

    Regarding the controlability it's indeed better with other cars but still not that intuitive. But that's maybe my missing practice. Of course I've already set it to rookie. ;-)

    But what's TCS and how do I use it?

    Arch Linux installs 1.4.0, btw.

  • Jean-Philippe Meuret

    I was meaning that our build system doesn't install the doc anywere when you  run "sudo make install" … and so this can explain the issue … even if I agree with you the Arch Linx packager could well have gone a bit further ;-)

    Ah .. 1.4.0 … IIRC, we had already made some changes (toward realism, at least we tried) to the car setups, as compared to TORCS 1.3.1 (from which we forked). IIRC, the LS1 where quite difficult to drive with binary control on the throttle (like keyboard) ; ASR / TCS helps a bit ; the Supercars were quite easy, whereas very understeery ; the TRB1 were a bit less easy (more power, more oversteering, touchy at the limits) ; and the 36 GP were very difficult, even with wheel / pedals.
    All the robots did well with all the cars (but not very fastly by the way, sometimes quite easy to overtake when you get used to their weaknesses and get to master the cars ).

    Oh, and don't forget that the official physics engine for 1.4.0 is Simu V2.0 : some cars behave very bad with Simu V3.

    TCS (Traction Control System) is named ASR (Anti-spin/slip System) in 1.4.0 … you can activate it (if not already done ; it is by default) while racing through a keyboard shortcut you can customize in the Player Configuration menu (Controls Configuration screen).

    The future 2.0 will do a great step ahead towards realism, both about car parameters (XML files) and about handling. Not to say it'll be easier … but we hope at least more intuitive, as far as driving a race car is intuitive ;-)

  • cyberpatrol

    cyberpatrol - 2011-08-18

    I had ASR activated and also used Simu V2.0. But I think I'll wait for 2.0.

    Thanks for the lot of infos. :-)

  • Jean-Philippe Meuret

    You're welcome :-)


Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks