BWidgets, IWidgets

  • Nobody/Anonymous


    I can't seem to get BWidgets or IWidgets to work reliably. I found the documentation for these and made the appropriate changes to teh SpecTclrc file, but I still get weird messages when SpecTcl tries to load. Has anyone been successfull using BWidgets with SpecTcl? If so how did you do it.

    • Nobody/Anonymous

      Actually it would be better to get Iwidgets going in a reasonable manner. Since I use tclpro and they are bundeled in.

      • Nobody/Anonymous

        Use something like the code below. If it still doesn't work, please give the entire text in the error message so that I have a better idea of what's wrong. I haven't actually really used these widgets. It would be nice to know your name.



        namespace eval :: {
        # Iwidgets: need to load [Incr Tcl] first
        package require Itcl
        namespace import itcl::*
        set ExtraWidgets(Iwidgets) [list iwidgets::notebook iwidgets::tabset iwidgets::watch]

        # BWidgets: need to rename commands because they start with
        # an upper case letter
        proc bwtree {args} {uplevel Tree $args}
        set ExtraWidgets(BWidget) [list bwtree]

    • Eric Merritt

      Eric Merritt - 2001-11-12

      Sorry about not signing in. In any case, when attempting to use the provided code (I did read the documentation btw). I get the message when trying to add a bwtree to the ui

      Error bad window path name ".can.f.bwtree#1"

      Iwidgets seem to be working for the most part. I there are several that do not seem to work. And when  using Iwidgets you can't build and run from within spectcl. btw I am using SpecTcl v1.2a3 and the latest version of TclPro for linux from activestate. In any case, thanks for the response, it may be that I need to upgrade my version of tcl it TclPro seem to use 8.3

      • Nobody/Anonymous

        After a bit more testing, I found that it is most fair to say that BWidgets is not supported by SpecTcl. SpecTcl relies on the widgets being thoroughly implemented, so that the widgets can provide SpecTcl with neccessary information about themselves. This is not the case with the version of BWidgets that I use (version 1.2.1).

        Could you give me a list of the Iwigdets that you have used that do not work (and a description of the problem)? It should not be necessary to upgrade your TclPro - My intention is that SpecTcl should work with Tcl/Tk versions 8.0 and greater (although version 8.2 should be avoided).

        If you add the lines below to your Preferences->Options->Output you will be able to build and run from SpecTcl.



        package require Itcl
        catch {namespace import itcl::*}

        package require Iwidgets
        catch {namespace import iwidgets::*}

        • Morten Skaarup Jensen

          I found that TkTable also was not working well enough. I have now fixed this bug, so the latest version from the CVS tree will work satisfactorily with TkTable.


    • Lan Barnes

      Lan Barnes - 2006-07-27

      I have not looked at the source for BWidgets. I wonder if MSJ would think that one (that'd be me) could hack the source to get ComboBox out, rename it comboBox, and install it in SpecTcl?

      This is exactly what I need as a widget, and my project is committed to SpecTcl, so it's worth the effort if it could work.


    • proshocks

      proshocks - 2006-08-25

      hi guys,

      sorry am not replying to the current askin one of my own question.

      am using specTCL for the first time and am finding problem in navigating from one interface to another.
      when i destroy one interface all the trames are destroyed with it.

      can u guys help me with this prob.

      thanx and regards,


Log in to post a comment.