#4 Index was outside the bounds of the array

closed-fixed
nobody
None
5
2010-03-28
2010-03-13
No

Hi,
I updated my n++ to the most recent version 5.6.8 (unicode) and I've got an error from SourceCookiefier plugin:
"Index was outside the bounds of the array"
See attached sample source files and error logs

Discussion

  • Michael Trofimov

    sample source code and error logs

     
  • UFO

    UFO - 2010-03-13

    Hi,
    I can't reproduce that behavior with the latest N++ version and your given files.
    Could you tell me when it exactly happens?
    Looking at your config file, you seem to be in "Single file mode", unless you changed it after starting N++.
    So it only happens when you press the "Refresh" button?

     
  • Nobody/Anonymous

    I get this exact error message too. I get it with the a regular expression, such as:

    INPUT: name=\\[\"\']([^\\|]+)\\ OUTPUT: \1

    Matched against:

    echo "<input name=\"[[TABLE|Update]]\" />";

    If I remove the | (line) character, the error no longer occurs. So it seems to be the line character. Hope this helps.

     
  • UFO

    UFO - 2010-03-28

    Thanks for reporting, I've reproduced and fixed it right now.
    You're right, the vertical line character caused the trouble,
    no matter if in input regex string or in source code itself.
    Hopefully I can soon finish the other stuff and release a new version.
    cheers

     
  • UFO

    UFO - 2010-03-28
    • status: open --> closed-fixed
     
  • UFO

    UFO - 2010-03-28
    • status: closed-fixed --> open-fixed
     
  • UFO

    UFO - 2010-03-28
    • status: open-fixed --> closed-fixed
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks