Windows version - error on load

Help
2003-12-05
2013-04-22
  • Nathanael Barbettini

    When I try to run the latest Windows version, I get this error:

    "The procedure entry point libiconv_set_relocation_prefix could not be located in the dynamic link library iconv.dll."

    I have GTK+ 2.0 installed. Any ideas why the program won't load?

     
    • Lauris Kaplinski

      I have seen this, but do not know, what exactly causes it :-(
      Copying all your dll dependencies to sodipodi program directory (and gtk+ lib, bin, etc and share directories as well) does solve it AFAIK.
      Btw, are you in Administrators group? Windows adds extra security check for everything run by administrator, so certain dll-s may not load (I have had such problem myself).

       
    • Nathanael Barbettini

      Yes, I am an administrator.

      So the solution is to copy all the GTK+ dlls to the sodipodi directory? I'll try it and let you know how it goes.

       
    • Roberto Fortunato

      I had the same problem. I resolve it moving the iconv.dll under sodipopodi directory even though it was just on the path. (I don't know if there is a problem of version: my dll version is 1.9.0.0)

       
    • Lauris Kaplinski

      I wonder whether it would be good idea to install iconv.dll to sodipodi program directory as well. I am only worried about what happens, if Gtk+ and sodipodi iconv.dll differ.
      As of administrator, AFAIK Win2000 does not search PATH for dll-s if you are in Administrator group (this is security feature).

       
    • Nathanael Barbettini

      Copying the GTK libraries worked, thanks again!
      Great piece of software, BTW!

       
    • Anonymous - 2004-02-14

      I suspect this is because winXP has its own iconv.dll in windows\system32.  As with everyone else who had this problem (probably everyone with winxp, I moved the iconv.dll from GTK folder to sodidpodi folder and all was well.

       
    • tripleshift

      tripleshift - 2005-04-24

      hi everybody,
      I recently tried to install 0.34 on XP and I had the error above mentioned.
      I tried to solve copying the dll's as said, but It simply keep giving me the error.
      I tried then with the 0.33-1 and it works.

      does anyone know what can be wrong with my system (apart that is XP ;) )?

       

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks