Missing font

Help
Rob E
2004-02-12
2004-05-06
  • Rob E

    Rob E - 2004-02-12

    Lauris,

    I keep getting the following message...

    "** (sodipodi.exe:4294063593): WARNING **: Couldn't load font "MS Sans Serif 8" falling back to "Sans 8""

    This is on Sodipodi 0.34, but it also happens in 0.33.  Installed on Windows 98SE.  Do I have too many fonts in my Font directory? I checked and I have 192 fonts in that directory. Or maybe I need another version of MS Sans Serif?  Either way, I don't know what is going on.

    Any help is appreciated.  Great program altogether!

    -tech

     
    • Lauris Kaplinski

      I do not know the cause of this warning, but as I have heard it happens on Gimp/Win32 too I bet it is Pango/Gtk+ related.
      You may look at config files in
      Program Files\Common Files\GTK\2.0\etc
      but I do not know what exactly has to be written there.

       
    • Jos Hirth

      Jos Hirth - 2004-02-28

      >I bet it is Pango/Gtk+ related.

      Yep. It's Pango. MS Sans Serif is a .fon file and not a .ttf and it doesn't like that :)

      Well there isn't anything you can really do about that bug itself... however, it's "workaroundable".

      Right Click on the desktop -> settings (or so) -> presentation (or so) and change there all fonts from "MS Sans Serif" to a ttf font... eg "Tahoma (Western)". That font is very similar.

      After that the flooding is gone :)

      My mouse runs at 200hz therefore it generates up to 200 events per second... each event triggers that warning message. That put my comp down to it's knees - kinda funny that those console text stuff takes so much cpu power. I'm wondering if MS did that in order to simulate the good old dos feeling ;D

       
    • Rob E

      Rob E - 2004-03-06

      amphi,
      I changed everything to Arial and it worked!  Thank you very much.  I think your workaround needs to be noted by GTK and devs that work with it, if it isn't already.  Although my PC could handle the flooding, I was just annoyed by that msdos screen.  Again, thanks.
      -tech

       
    • Anonymous - 2004-05-06

      "Tahoma (Western)" cleared up the problem for me, also.  Thanks.

       

Log in to post a comment.