Ken Maier - 2003-04-21

Here's something I cannot figure out.  Anyone have any clues as to why this might be happening?

My ISP upgraded the Linux kernel on one of their machines from 2.4.18 to 2.4.20.  This upgrade has caused the following code to stop working:

include "Snoopy.class.inc";
$snoopy = new Snoopy;
$snoopy->fetch("http://www.carprices.com/");
print $snoopy->results;

I have a 2nd machine still running 2.4.18 and this code works perfectly..  on the 2.4.20 machine it spits out the following error message:

Warning: fsockopen() [function.fsockopen]: php_hostconnect: connect failed in /home/autodeal/public_html/includes/Snoopy.class.inc on line 1061

Warning: fsockopen() [function.fsockopen]: unable to connect to www.carprices.com:80 in /home/autodeal/public_html/includes/Snoopy.class.inc on line 1061

Any clues?  I'm purplexed.

Thanks

-ken