#235 SMPlayer crashed when playing HD MP4

version_0.x.x
closed-fixed
windows (109)
9
2009-01-11
2009-01-10
David
No

SMPlayer (Version: 0.6.6 (SVN r2599)) keeps crashing when I attempt to play MP4 file of high resolution (1280 x 720).

The file is not corrupted as it can be viewed with another player (VLC Media Player 0.9.8a) flawlessly.

I played another MP4 file of >800MB size but with a resolution of 640 x 480, SMPlayer didn't crash at all.

Discussion

  • David

    David - 2009-01-10

    MPlayer log during crash.

     
  • David

    David - 2009-01-10
    • assigned_to: nobody --> rvm
    • priority: 5 --> 9
     
  • David

    David - 2009-01-10
    • summary: SMPlayer crashed when HD MP4 --> SMPlayer crashed when playing HD MP4
     
  • Ricardo Villalba

    Does it crash too if you set the "threads for decoding" to 1?

     
  • Ricardo Villalba

    • status: open --> pending
     
  • David

    David - 2009-01-11

    Still crash when Thread set to 1.

     
  • David

    David - 2009-01-11
    • status: pending --> open
     
  • David

    David - 2009-01-11
     
  • David

    David - 2009-01-11

    I forgot to mention....

    There seems to be a bug with MP4 playback.

    Please check out the new log.

     
  • Ricardo Villalba

    • status: open --> pending
     
  • Ricardo Villalba

    There's no crash in this new log. It just says your computer is slow.

    Things you can try:
    * set the cache to 0
    * set the "correct pts" option (Preferences->Advanced) to "auto"
    * change the demuxer from "lavfpref" to "mov"

     
  • David

    David - 2009-01-11

    Thanks a lot!!! You've been very helpful.

    SMPlayer no longer crashes after setting "Correct pts".

    And no more slow playback (MP4 only) after setting the cache for local files to 0.

     
  • David

    David - 2009-01-11
    • status: pending --> open-fixed
     
  • Ricardo Villalba

    • status: open-fixed --> closed-fixed
     

Log in to post a comment.