#115 Segmentation fault when unloading subtitles

closed-works-for-me
nobody
None
5
2008-03-13
2008-03-12
Anonymous
No

When the player is in fullscreen with subtitles loaded, if you unload them it crashes giving a segmentation fault.

Konsole debug messages:

Debug: MplayerProcess::parseLine: 'ID_AUDIO_CODEC=mp3'
Debug: MplayerProcess::parseLine: 'Comenzando la reproduccin...'
Debug: MplayerProcess::parseLine: 'VDec: vo solicitud de config - 608 x 288 (csp preferida: Planar YV12).'
Debug: MplayerProcess::parseLine: 'VDec: usando Planar YV12 como salida csp (no 0)'
Debug: MplayerProcess::parseLine: 'Aspecto es 1.80:1 - prescalando a aspecto correcto.'
Debug: MplayerProcess::parseLine: 'ID_VIDEO_ASPECT=1.8042'
Debug: MplayerProcess::parseLine: md.video_aspect set to 1.804200
Debug: MplayerProcess::parseLine: 'SwScaler: reducing / aligning filtersize 1 -> 4'
Debug: MplayerProcess::parseLine: 'SwScaler: reducing / aligning filtersize 1 -> 4'
Debug: MplayerProcess::parseLine: 'SwScaler: reducing / aligning filtersize 5 -> 4'
Debug: MplayerProcess::parseLine: 'SwScaler: reducing / aligning filtersize 5 -> 4'
Debug: MplayerProcess::parseLine: '[swscaler @ 0x87cc994]SwScaler: BICUBIC scaler, from yuv420p to rgb24 using MMX'
Debug: MplayerProcess::parseLine: '[swscaler @ 0x87cc994]SwScaler: using 4-tap MMX scaler for horizontal luminance scaling'
Debug: MplayerProcess::parseLine: '[swscaler @ 0x87cc994]SwScaler: using 4-tap MMX scaler for horizontal chrominance scaling'
Debug: MplayerProcess::parseLine: '[swscaler @ 0x87cc994]SwScaler: using n-tap MMX scaler for vertical scaling (BGR)'
Debug: MplayerProcess::parseLine: '[swscaler @ 0x87cc994]SwScaler: 608x288 -> 608x336'
Debug: MplayerProcess::parseLine: 'VO: [x11] 608x288 => 608x336 Planar YV12 [zoom]'
Debug: Core::gotVO: 'x11'
Debug: Core::gotWindowResolution: 608, 336
Debug: BaseGuiPlus::resizeWindow: 608, 336
Debug: BaseGui::resizeWindow: 608, 336
Debug: MplayerProcess::parseLine: 'X11 error: BadAccess during XSelectInput Call'
Debug: MplayerProcess::parseLine: 'X11 error: The 'ButtonPressMask' mask of specified window has probably already used by another appication (see man XSelectInput)'
Debug: MplayerProcess::parseLine: 'X11 error: MPlayer discards mouse control (reconfiguring)'
Debug: MplayerProcess::parseLine: 'X11 error: BadAccess during XSelectInput Call'
Debug: MplayerProcess::parseLine: 'X11 error: The 'ButtonPressMask' mask of specified window has probably already used by another appication (see man XSelectInput)'
Debug: MplayerProcess::parseLine: 'X11 error: MPlayer discards mouse control (reconfiguring)'
Debug: MplayerProcess::parseLine: starting sec: 3336.900000
Debug: Core::gotStartingTime: 3336.900000
Debug: Core::gotStartingTime: current_sec: 3336.300000
Debug: Core::finishRestart
Debug: Core::finishRestart: processing new subtitles
Segmentation fault

Discussion

  • Ricardo Villalba

    Logged In: YES
    user_id=115931
    Originator: NO

    You forgot to say what version you're using.

    Using here smplayer svn r943 in linux. I can't reproduce your problem. No crash.

     
  • Ricardo Villalba

    • status: open --> closed-works-for-me
     

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:





No, thanks