#9 "Building Carp-Clan-5.9" hangs

closed-fixed
nobody
None
5
2007-09-19
2007-09-05
No

************************************************

Building Carp-Clan-5.9

************************************************

Running 'perl Makefile.PL LIB=/Users/schwern/devel/smolder/lib PREFIX=/Users/schwern/devel/smolder/tmp/Rny5avj1s2/Carp-Clan-5.9/../trash INSTALLMAN3DIR=' ' INSTALLMAN1DIR=' ''...
Add Object::Deadly 0.08+ to prerequisites for testing? [Ny] [no]

At this point the build hangs. Return and ctrl-d have no effect.

Discussion

  • Michael Peters

    Michael Peters - 2007-09-19

    Logged In: YES
    user_id=1387047
    Originator: NO

    I hate modules that prompt for things like that during install. At least give me a way to override that...

    Anyways, I've committed a fix to svn. If you can, please check svn, if not, I'll have it in the next release (1.21).

     
  • Michael Peters

    Michael Peters - 2007-09-19
    • status: open --> open-fixed
     
  • Michael Peters

    Michael Peters - 2007-09-19
    • status: open-fixed --> closed-fixed
     
  • Michael G Schwern

    Logged In: YES
    user_id=12221
    Originator: YES

    > I hate modules that prompt for things like that during install. At least
    > give me a way to override that...

    Since it's using ExtUtils::MakeMaker::prompt(), like a good module should, you make it take the default by setting PERL_MM_USE_DEFAULT=1

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks