I didn't try your CVS workaround, but I followed your other try another channel suggestions, one try Oracle and the other Red Hat with bugzilla.  Red Hat came back with we don't support this product, but I did receive a suggestion from an Oracle Tech/Linux Forum.  Here is what I got:  Get the rpm-src for smarttools from the link below

ftp://rpmfind.net/linux/fedora/core/development/source/SRPMS/smartmontools-5.37-2.fc7.src.rpm

then run

1.rpmbuild --rebuild smartmontools-5.37-2.fc7.src.rpm
2.rpm -ivh --force --nodeps /usr/src/redhat/RPMS/i386/smartmontools-5.37-2.i386.rpm
3.service restart smartd

I tried these steps and from all indications by gollie it looks like we may have solved the smartd crisis.  After these steps when I man smartd it give me the updated version of 5.37 of Smartmontools. Also, after a reboot it looks like the service is running, since I didn't get a failure and when I look at services it says it is running.
 
However, I am not sure if this is a complete fix so wanted to bounce this back off you smartmontools gurus.  Would we have a way of testing a failure without actually having a failure, just to be sure this is monitoring? Also, would any changes need be applied to the smartd.conf file, such as making it monitor controller CCISS?
 
 
Thanks for the help!
 




-----Original Message-----
From: Michael Mansour [
mailto:mic@npgx.com.au]
Sent: Saturday, April 21, 2007 9:47 PM
To: Chuck Noga - CAN; smartmontools-support@lists.sourceforge.net
Subject: Re: [smartmontools-support] smartd service failure

> To whom it may concern,
>
> We have just loaded Unbreakable Linux 4 on a new HP Proliant DL360

Yes, this is just a derivative of RHEL4, thanks to Oracle's Ellison.

> Server. The server has a HP Smart Array Raid controller that is
> recognized as a CCISS drive in Linux. From the get go, and after doing
> all ULN required updates, this service on start was failing, smartd.

By default the service will always fail on HP Proliant Servers, this is because the smartmontools version packaged with Red Hat 4 is quite old (5.33) and doesn't support cciss controllers.

You have an option of suggesting to Oracle to upgrade it, since being their distribution they have the option to do that without sticking to Red Hat's packaged environment. I'd suspect they won't do this though, or maybe raise a bugzilla with Red Hat asking for an upgrade?

> After doing some research it look like version of smartmontools that
> came packaged with our version of the Unbreakable Linux 4 is version
> 5.33 . I checked your Homepage

Red Hat don't use a smartmontool "RPM package", they instead package it into the kernel-utils RPM package.

> (
http://smartmontools.sourceforge.net/) and it looks like the more
> recent version of this package, smartmontools
> v.5.37 supports this CCISS (Compaq Smart Array Controller) for Linux
> and was added 2006-10-09. Long story short, it looks like we may need
> to upgrade this package, from 5.33 to 5.37, and I was wondering if
> anyone has any details on obtaining this package or any other
> suggestions on getting this smartd service to work?

Go to the smartmontool sourceforge download page, read the instructions for downloading the CVS version, then install from that:

./autogen
./make
./make install

then modify the /etc/init.d/smartd script to reference the updated instance of smartd located in /usr/local/sbin then configure the controllers in the /usr/local/etc/smartd.conf then restart the service.

tail the /var/log/messages file to see your newly monitored drives.

> Thanks for your help and time in advance.

Cheers.

Michael.

> Chuck
------- End of Original Message -------