Folks:

 

I am using Centos 5.5 with kernel 2.6.18-92.  In looking at sys log when trying to run in captive mode I get

Exception Emask 0x0 sAct 0x0 SErr 0x0 action 0x2 frozen

Cmd b0/d4:00:81:4f:c2/00:00:00:00:00/00 tag 0

Res 40/00:00:00;4f:c2/00:00:00:00:00/00 Emask 0x04 (timeout)

Status: {DRDY }

Soft resetting link

SATA link up 3.0 Gbps (SStatus 123 SControl 300)

Configured for udma/133

EH complete

488281250 512-byte hdwr sectors

Write protect is off

Scsi device sdb: drive cache: write back

 

This appears when the command smartctl –t short –C /dev/sdb is issued.    

The error comes in at  (41) for the register so 0x29 for the status which is the reset at 90% left.

 

When running the test without the –C option the test completes fine.

 

I am leaning that this is maybe a kernel problem.  We a different motherboard system, but using a higher rev 2.6.18 kernel and I still get the problem with captive mode, but not with background mode, and the disk drives are completely different disks.

 

Has anyone run into this problem where captive wouldn’t work, background would for this test.  Long test in captive mode produces same result.

 

Brian