For the past week or so I have been trying to troubleshoot why there is no SMART info available from my drives.

There are two SATA drives on an ASUS A8V Deluxe motherboard. The drives are on the VIA SATA Raid controller (but they are not configured as RAID). The BIOS is picking up the drives on the serial channels 0 and 1 (and there is nothing detected on Primary/Secondary IDE master/slave)

The first drive is a Western Digital
WD740GD and it does support smart as indicated here: http://www.wdc.com/en/library/sata/2879-001069.pdf
"Built for enterprise environments – includes Enterprise Extensions S.M.A.R.T. Accessed
(EESA), an expanded command set that provides SCSI-like control for server environments,
as well as Rotary Acceleration Feed Forward (RAFF™) that optimizes operation and
performance when the drives are used in vibration-prone multi-drive systems, such as
rack-mounted servers.

The second drive is a Seagate Seagate ST380817AS and it does support smart as indicated on page 33 here:

The WD740 is the boot drive with windows 2000 installed on it. The Seagate is a backup drive on a removable tray (so it is not always on)

1. I have attempted several HD monitoring utilities and none is able to accurately detect SMART info out of the drives. Most utilities report that SMART is not supported, but at the same time they give some values in the attributes screens. These values are probably bogus because both drives are shown with identical SMART attributes which is a suspicious behavior.
Utilities I tried so far
Lavalys Everest
HardDrive Inspector
WesternDigital Data Lifeguard tools
Personal SmartCheck

2. In the process of troubleshooting I discovered this article:
So I took out the WesternDigital drive and changed the jumper as indicated. However, this had no effect at all.
(Also, the seagate drive has no such jumper)

3. Updated all VIA drivers for this motherboard to the latest Hyperion drivers

4. I tried to run smartmontools on windows2000 and I get something like this:
C:\>smartctl -a /dev/hda
smartctl version 5.37 [i686-mingw32-2000-sp4] Copyright (C) 2002-6 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

Model Family:     Western Digital Raptor family
Device Model:     WDC WD740GD-32FLA0
Serial Number:    WD-WMAKE1024101
Firmware Version: 21.08U21
User Capacity:    9,126,807,040 bytes
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   1
ATA Standard is:  Exact ATA specification draft version not indicated
Local Time is:    Sat Apr 21 14:34:44 2007 EDT
SMART is only available in ATA Version 3 Revision 3 or greater.
We will try to proceed in spite of this.
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 82-83 don't show if SMAR
T supported.
                  Checking for SMART support by trying SMART ENABLE command.
                  SMART ENABLE appeared to work!  Continuing.
SMART support is: Ambiguous - ATA IDENTIFY DEVICE words 85-87 don't show if SMAR
T is enabled.
A mandatory SMART command failed: exiting. To continue, add one or more '-T perm
issive' options.

I am not sure why it says ATA version=1 and then "SMART is only available in ATA Version 3".
This drive is a second generation serial ATA and should have should have full SMART support as indicated in the links mentioned earlier. No ?

5. To make sure it is not a Windows issue or a driver issue ... I booted from a Knoppix 5.10 liveCD and run smartmontools through that. The drives were being picked up as sdba1 and sdba2, but the error persisted "A mandatory SMART command failed"

6. Send an email to ASUS support, but as I was asking about drives they sent me a canned response (something completely irrelevant about system stability and memory ... so I do not expect them to be of any help)

>From your experience, have you seen a problem like this before ? Do you think there is any chance I will be able to reliably access the SMART data of these drives ? Should I give up ?

Many thanks in advance and apologies for the lengthy text.