Hi Wayne,



The problem is that you don’t have the net components jar file in your daemon classpath.



That example uses #include for the ftp component using a notation to load the description from a .jar file. In any case, you should get use to put all your .sf and classes in jar files because it is mandatory to be able to use security.


Go to components/net and type “ant install”. This command will compile the components, create the needed jar files and then copy them to $SFHOME/lib.


Now you could start the daemon and everything should work.



From: Yuxiang Wu [mailto:wu@dcs.gla.ac.uk]
Sent: 20 August 2007 15:19
To: Guijarro, Julio
Subject: RE: start sfDaemon help

   When I run smartfrog net component ftpExample, it always displays this error:

- FAILED when trying DEPLOY of 'TEST1',  [example.sf],  host:localhost
      * Exception: 'SmartFrogDeploymentException: unnamed component. deploying description 'example.sf' for 'TEST1'
        cause: SmartFrogResolutionException::
           Cause: Error creating parser for 'example.sf'. Parser error [SmartFrogParseException:: org.smartfrog.sfcore.languages.sf.ParseException: Parsing include file /org/smartfrog/services/trace/ftp.sf : Include file: /org/smartfrog/services/trace/ftp.sf not found, cause: org.smartfrog.sfcore.languages.sf.ParseException: Parsing include file /org/smartfrog/services/trace/ftp.sf : Include file: /org/smartfrog/services/trace/ftp.sf not found]
        deployedContext: included'

but actually, /org/smartfrog/services/trace/ftp.sf does exist. Also the CLASSPATH is set to the current directory.


Could you give me a hand? Thank you very much



From: Yuxiang Wu [mailto:wu@dcs.gla.ac.uk]
Sent: 14 August 2007 15:08
To: Guijarro, Julio
Subject: RE: start sfDaemon help

Hi Julio,

   That's OK. I think it is the CLASSPATH problem. Thank you for your



From: Guijarro, Julio [mailto:julio_guijarro@hp.com]
Sent: 2007-8-13 15:35
To: smartfrog-support@lists.sourceforge.net; Yuxiang Wu
Subject: FW: start sfDaemon help

HI Wayne,

How did you intall SmarFrog? Are you using the an svn checkout, a full
distribution or an rpm distribution? What version are you using?

If you are running an RPM-based distribution, start with the RPMS. They
should also work on debian systems, though they don't set up the
environment properly there.

>From the information you provided, I think your problem could be that
SFHOME should be pointing to /usr/local/SmartFrog/dist, but without more
information I cannot be sure.




From: sitelist-bounces@lists.sourceforge.net
[mailto:sitelist-bounces@lists.sourceforge.net] On Behalf Of Yuxiang Wu
Sent: 13 August 2007 12:36
To: smartfrog-support-owner@lists.sourceforge.net
Subject: start sfDaemon help

Hi list,

   I just started to use SF. I start-up sfDaemon in Window successfully.
But when I run sfDaemon in Linux shell command line, there is a

Exception in thread "main" java.lang.NoClassDefFoundError:
        at org.smartfrog.SFSystem.sfLog(Unknown Source)
        at org.smartfrog.SFSystem.initSystem(Unknown Source)
        at org.smartfrog.SFSystem.execute(Unknown Source)
        at org.smartfrog.SFSystem.main(Unknown Source)

My environment is:


Could you tell me what is wrong? Thanks a lot