Linux version

  • Denis

    Denis - 2007-08-29

    Do you planing create linux version for receive video from Symbian?

    • deion

      deion - 2007-08-29

      A linux version is a very interesting ideea, however I don't believe it will be implemented in the near future...Perhaps some Linux gurus could give a hand :) ?

    • Denis

      Denis - 2007-08-29

      I want to try when I'll have a time.
      And I think that access to camera over internet(IP) will be good feature.
      But now I want to see how it's work with windows :)

    • Juan Roldan Ruiz

      Works great under Debian Lenny using a Nokia N70.

      Congratulations for the project!


  • Jan Abrahamcik

    Jan Abrahamcik - 2009-10-21

    Hi, thanks for the effort you put into creating Linux version, but I'm having problems compiling the kernel module. I've got Debian stable/testing and was trying to compile the module from the latest source for a different kernels Here are outputs for different kernels:
    2.6.30-686: The same as above

    When I tried to comment the problematic part in the first two kernels(commenting line 599 in smartcam.c : //.vfl_type=VID_TYPE_CAPTURE), the module compiles. But when I try to run smartcam application, I get "Cannot open '/dev/video0': 14, Bad address"
    Anyone havean idea, what am I doing wrong?
    Thanks for your reply

  • Andy Hull

    Andy Hull - 2010-01-09

    Issues compiling and running under Ubuntu 9.10

    I can complile the Smartcam application, but the output when I run it indicates a segmentation fault…

    $ smartcam
    smartcam: registered DBUS service "org.gnome.smartcam"
    Cannot open '/dev/video0': 14, Bad address
    Cannot identify '/dev/video1': 2, No such file or directory
    Cannot identify '/dev/video2': 2, No such file or directory
    Cannot identify '/dev/video3': 2, No such file or directory
    Cannot identify '/dev/video4': 2, No such file or directory
    Cannot identify '/dev/video5': 2, No such file or directory
    Cannot identify '/dev/video6': 2, No such file or directory
    Cannot identify '/dev/video7': 2, No such file or directory
    Cannot identify '/dev/video8': 2, No such file or directory
    Cannot identify '/dev/video9': 2, No such file or directory
    smartcam: started comm thread
    smartcam: port = 1
    Segmentation fault

    I comiled the module (commented out the above line) and it loads, but thats as far as I managed to get, any ideas?

  • Andy Hull

    Andy Hull - 2010-01-10

    Can I connect over IP from Linux? If so, how?

  • ghostnik11

    ghostnik11 - 2011-03-26

    Hi I am having problems compiling for ubuntu 10.10 with this kernel: 2.6.35-28-generic.  I keep getting this when i tell it to compile driver, and wanted to know how i could go about fixing the problem

  • Dennis

    Dennis - 2011-04-01

    I can confirm this! Sadly, there is no 64 bit .deb package of smartcam available for my 64 bit Ubuntu 10.10, so I tried to compile the smartcam 1.4 driver from the source myself. I ran into the same issue, ghostnik11 (and others) have. I'll add information about this to an existing bug or create a new one.

    Thanks in advance for helping us out!


  • Dennis

    Dennis - 2011-12-22

    Addendum to my last comment from 1st Apr 2011:

    I finally realized that the SmartCam project consists of more parts than I thought. On the PC side the smartcam driver AS WELL as the smartcam program has to be running to 'tunnel' the video data from (Bluetooth, WiFi? ..) to the smartcam driver which then provides the video stream to other application layer programs like Cheese, Skype(?) etc. - I guess.

    Now, more than 8 months later, I'm still using …

    Ubuntu 10.10 (Maverick) 64 bit (with kernel "2.6.35-31-generic #63-Ubuntu" now),

    because it is so great, and I finally was able to get the smartcam driver component compiling without errors! Thanks a lot to some postings on the bug tracker (about patching, patching and patching) and due to some investigations in missing -dev packages (installing those build depends before the compilation process). So I got the smartcam.ko kernel driver successfully compiled and loaded - but not the smartcam program!

    For more details, please see my bug report, that I'll file in few seconds.

    Kind regards,


  • Olzaq

    Olzaq - 2012-09-04

    Diff to get module compiled in Ubuntu 10.04 with 2.6.32-42-generic


    > #include <linux/sched.h>
    <   .vfl_type       = VID_TYPE_CAPTURE,
    >   .vfl_type       = VFL_TYPE_GRABBER,

    Diff to get smartcam started because of bluetooth problems:
    diff UserSettings.h* :

    <     static const ConnectionType SMARTCAM_DEFAULT_CONNECTION_TYPE = CONN_INET;
    >     static const ConnectionType SMARTCAM_DEFAULT_CONNECTION_TYPE = CONN_BLUETOOTH;
  • Olzaq

    Olzaq - 2012-09-04

    There was already working patch. Ignore previous mail and use patch from here:

    After this the driver actually works, smartcam detects the driver and skype sees the device:

    [16401.315865] smartcam:(insmod) load status: 0
    [16401.373624] smartcam:(v4l_id) smartcam_open called
    [16401.373641] smartcam:(v4l_id) vidioc_querycap called
    [16401.373727] smartcam:(v4l_id) smartcam_release called
    [16401.390528] smartcam:(LVAP0 thread) smartcam_open called
    [16401.390545] smartcam:(LVAP0 thread) vidioc_querycap called
    [16401.390699] smartcam:(LVAP0 thread) vidioc_enum_fmt_cap called, index=0
    [16401.390708] smartcam:(LVAP0 thread) vidioc_enum_fmt_cap called, index=1
    [16401.390715] smartcam:(LVAP0 thread) vidioc_enum_fmt_cap called, index=2
    [16401.390723] smartcam:(LVAP0 thread) smartcam_release called
    smartcam: registered DBUS service "org.gnome.smartcam"
    Found smartcam device file: /dev/video0
    smartcam: started comm thread

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.

No, thanks