Running the enironment - HOW TO?

Help
Ron Brown
2009-10-02
2013-04-25
  • Ron Brown

    Ron Brown - 2009-10-02

    I breezed through the setup (pretty good document) - of course I already had all the right stuff installed, but the environment was still new enough that I had to dig around to figure out how to START things working.

    Using the default on every thing, to run the whiteboard daemon and SIB over TCP, in the same machine (i.e. whiteboard discovery of SIB at address 127.0.0.1). one needs to start three process: /usr/local/bin/whiteboardd /usr/local/bin/sibd /usr/local/bin/sib-tcp

    The trap for newbies being, that the whiteboardd starts its own transport layer, while the sibd does not.

    Some simple getting-startied documentation is probably needed, or update to the setup document.

     
  • Neill Whillans

    Neill Whillans - 2009-10-06

    I tried the exact same set-up, with all the required packages installed, all the default settings, etc. I then tried to run the 3 processes you mentioned.

    The whiteboard (and its associated transport layer) started without any problems, however whenever I tried to start the SIB daemon, I had the following error:

    *File "/usr/lib/python2.6/dist-packages/wilbur_m3.py", line 53, in __init__
        self.db = piglet.open(self.home+'/'+dbfile)

    TypeError: unsupported operand type(s) for +: 'NoneType' and 'str'*

    Which looks to be an issue with a database. Am I supposed to create one myself? If so there isnt any mention of this in the setup guide?

    Can any shed any light on what I might be doing wrong?

    Thanks, in advance,

    Neill

     
  • Hannu Laine

    Hannu Laine - 2009-10-06

    The database file created  is PIGLET\_HOME/X where PIGLET\_HOME is a environmental variable pointing to a directory. It seems that if PIGLET\_HOME is not set, there is no default location for the database file. Furthermore, the directory PIGLET\_HOME points to much exist in before starting sib-daemon.

    Note that the contents of the database file is read during startup of the sib-daemon, so remove the database file if you want to start from empty database.

    Documentation how to run things will be added shortly.

    Regards,
    -Hannu

     
  • Neill Whillans

    Neill Whillans - 2009-10-07

    Thanks. That solved the problem :)

     
  • Matti Eteläperä

    I'm currently only interested in running the SIB so I have not installed all of the packages. Running sibd  I get the following error:
       
        Traceback (most recent call last):
          File "/usr/local/lib/python2.6/site-packages/rdfplus_m3.py", line 41, in <module>
            import wilbur_m3
          File "/usr/local/lib/python2.6/site-packages/wilbur_m3.py", line 41, in <module>
            import piglet
        ImportError: /usr/local/lib/python2.6/site-packages/piglet.so: undefined symbol: _Py_ZeroStruct

    Does this sound familiar, or do I have some kind of a problem with my development environment? On the other hand, importing piglet.so from the python prompt seems to work…

     

Log in to post a comment.

Get latest updates about Open Source Projects, Conferences and News.

Sign up for the SourceForge newsletter:

JavaScript is required for this form.





No, thanks