Compiling Windows version with Ubuntu Linux

Jens G.
2009-08-17
2013-06-03
  • Jens G.

    Jens G. - 2009-08-17

    Hi all!

    Since two days I try to compile Slash'Em 0.0.8E0F1 for my Windows Vista, but I still have no clue, where I should begin. I tried Cygwin and MingW with the readmes in the package, but it didn't work for me. I really miss a step-for-step tutorial for absolute self-compiling newbies...

    Anyway, I managed to compile a version with Ubuntu. Now I've got a Linux version without graphics, but what I like is a Windows version with nice 2D tiles.. :)
    Is there a simple solution to make it with Linux or do I have to make it in Windows? And if yes- how?

    Greetings, Jens

     
    • J. Ali Harlow

      J. Ali Harlow - 2009-08-18

      If you want a Windows version then, yes, you will need to compile under Windows. It's possible that the problem is that the instructions need modifying for use under Vista. If so, you're probably on your own. I, at least, have never used it.

       
    • Jens G.

      Jens G. - 2009-08-18

      Hmm... That's bad.
      I just tried it with Microsoft Visual C++ 2008 but it doesn't like the dsp-files. It wants to convert them, but this fails.

      When I try to compile it with mingw, it says sometime:
      (I installed MingW in C:\Programmierung\MingW)

      gcc -mms-bitfields -c -O -I../include -DDLB -DWIN32CON -I../win/win32 -D_WIN32_I
      E=0x0400 -owinhack.o ../win/win32/winhack.c
      In file included from C:/Programmierung/MingW/bin/../lib/gcc/mingw32/3.4.5/../..
      /../../include/objbase.h:4,
                       from C:/Programmierung/MingW/bin/../lib/gcc/mingw32/3.4.5/../..
      /../../include/shlwapi.h:12,
                       from ../win/win32/winhack.c:16:
      C:/Programmierung/MingW/bin/../lib/gcc/mingw32/3.4.5/../../../../include/rpcndr.
      h:52: error: conflicting types for 'boolean'
      ../include/global.h:76: error: previous declaration of 'boolean' was here
      mingw32-make: *** [winhack.o] Error 1

      Any idea what it might be?

       
    • Jens G.

      Jens G. - 2009-08-20

      Okay... After I played around with the files I've got a last problem before the goal.

      I compiled with MingW and got sometime the error "No tiles created! (check line end character sequence for your OS)." This happens in the file slashem\win\share\tile2bmp.c

      How can I solve this problem? If this error didn't happen, the compiling would finish successfully, so this is the last obstacle!

      Greetings, Jens

       

Log in to post a comment.