On Oct 4, 2006, at 2:08 PM, Anand Nimmagadda wrote

Hi All,
I am trying to install Slash on Fedora Core 5 with following versions,
 
apache 1.3.37
mod_perl-1.29
expat-1.95.8-8.2
expat-devel-1.95.8-8.2
perl v5.8.8
MySQL-server-4.1.21-0 (from rpm)
MySQL-client-4.1.21-0 (from rpm)
MySQL-devel-4.1.21-0 (from rpm)

I would use MySQL v5.x. See Slashcode's INSTALL for more information.

 
I installed MySql server, client and devel rpms first and then installed mod_perl and apache with following commands.
perl Makefile.PL APACHE_SRC=/usr/download/apache_1.3.37/src DO_HTTPD=1 \
>USE_APACI=1 PERL_MARK_WHERE=1 EVERYTHING=1 \
> APACHE_PREFIX=/usr/local/apache
make
make test
make install
Didnt notice any errors with the installation except couple of errors with make test as described in the install doc

you should be able to apachectl configtest  and have it come out w/ no errors at that point.
you should be able to fire up httpd and get the stock apache-is-installed page, too, at this point.

 
Then installed Bundle::Slash after installing CPAN update. Got some error with Time::Calendar and had to do a Force Install.

No suprise. There are several perl modules that you have to install by hand. No biggie. Most of them are installed via the Bundle, thankfully.

 
When I tried installing slash (R_2_5_0_94), received following messages

Why R_2_5_0_94?

 
Writing Makefile for Slash::Apache::Banlist
Writing Makefile for Slash::Apache::Log
Writing Makefile for Slash::Apache::TemplatePages
"strip" is not defined in %Slash::Constants::EXPORT_TAGS at /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Slash/Constants.pm line 44

Did you check Slashcode's SF bug list for this?

Did you grab a checkout of CVS HEAD and do a make install and see if you still see the 'strip not defined' problem?

 
install didnt stop here, and received a successful installation message.
 
When I tried creating a slash site, received following error,
 
# ./install-slashsite -u virtslash
"people" is not defined in %Slash::Constants::EXPORT_TAGS at /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Slash/Constants.pm line 29
Can't continue after import errors at /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Slash.pm line 29
BEGIN failed--compilation aborted at /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi/Slash.pm line 29, <DATA> line 139.
Compilation failed in require at ./install-slashsite line 19, <DATA> line 139.
BEGIN failed--compilation aborted at ./install-slashsite line 19, <DATA> line 139.
I couldnt find any message in the archives with the similar problem. can some one please help me to troubleshoot this.
 
Thank you
Anand


You might want to grab CVS HEAD, or latest t-tag, and use that. I just did an install on my laptop w/ the latest CVS-HEAD and it make installs and install-slashsite's a brand new working site just fine.

 Shane




--
My slashcode stuff: http://slash.lottadot.com
Slashcode faq: http://slash.lottadot.com/slash-faq
How to ask a question: http://www.catb.org/~esr/faqs/smart-questions.html#before